mount.cifs sec=ntlm

Issues related to applications and software problems
Post Reply
linuxlion
Posts: 1
Joined: 2019/11/15 07:58:38

mount.cifs sec=ntlm

Post by linuxlion » 2019/11/15 08:06:23

We use centos release 7.7.1908 (core)
I tried the mount command below:
mount.cifs -o domain=rubber.com,username=admin,password=password,iocharset=utf8,sec=ntlm //prod02/custom /mnt/share --verbose
According to the manual page mount.cifs the security mode "sec=" allowed the value "ntlm".
But the use of "sec=ntlm" result in "mount error(22): Invalid argument".

The use of "sec=none" result in "mount error(13): Permission denied".
The use of "sec=krb5" result in "mount error(126): Required key not available".
Without the use of "sec=", the mount succeed but is read-only.

On Ubuntu Linux the use of "sec=ntlm" succeed in a writable mount.

Is this a know restriction in Centos?

User avatar
KernelOops
Posts: 102
Joined: 2013/12/18 15:04:03
Location: xfs file system

Re: mount.cifs sec=ntlm

Post by KernelOops » 2019/11/15 22:48:55

I think the default security mode, if you don't set it or if you set it empty (sec=) is ntlmssp

But that I don't see why that affects the share's ability to be writeable or not. Maybe that is the cause of another parameter? did you check for any SELinux errors just in case SELinux blocks write access?
--
I love my computer - all my friends live there.
--

Post Reply

Return to “CentOS 7 - Software Support”