Libvirt 4.5.0-23 bug?

Issues related to applications and software problems
Post Reply
Arreth
Posts: 4
Joined: 2019/11/21 07:52:56

Libvirt 4.5.0-23 bug?

Post by Arreth » 2019/11/21 08:43:10

Hello,
it's hard to find any information so i wanted to talk it about here.
I'm using
qemu-kvm-common-ev-2.10.0-21.el7_5.7.1.x86_64
qemu-kvm-ev-2.10.0-21.el7_5.7.1.x86_64 and
libvirt-4.5.0-10.el7_6.3.x86_64 for my virtualization setup.
Live migrated all my vm's before updating the server and before libvirt was updated to 4.5.0-23 everything was working fine after the update i can't live migrate or create VM's with libvirt at 4.5.0-23 version i get the error: qemu-kvm: kvm_init_vcpu failed: Cannot allocate memory.
More information about my system:
CentOS Linux release 7.6.1810 (Core)
4.4.166-1.el7.elrepo.x86_64
Tried updating qemu-kvm and the kernel to 4.4.202 to newest version but still it did not work.

Does anyone have more information about this or where could i report this bug?
Or where i could find the change logs for the libvirt packages?

Thank you in advnace!

User avatar
TrevorH
Forum Moderator
Posts: 27138
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Libvirt 4.5.0-23 bug?

Post by TrevorH » 2019/11/21 08:51:02

I'm using that libvirt version and have no problems live migrating VMs from one server to another. However, I'm using all stock packages and not the Virt SIG qemu-kvm-ev* ones. I'm also using the CentOS distro kernel. I'm also running 7.7 and not 7.6 with bits of 7.7 added on.

Also, looking at the repos, you are a long way back on those Virt SIG packages. Current is qemu-kvm-ev-2.12.0-33.1.el7_7.4.x86_64.rpm dated Nov 14th. Yours is more than a year older than that.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Arreth
Posts: 4
Joined: 2019/11/21 07:52:56

Re: Libvirt 4.5.0-23 bug?

Post by Arreth » 2019/11/21 09:02:08

Hi, i know that my qemu-kvm-ev is a bit old, but it's because on top of everything i am using cloudstack (cloudstack does has a bug where he can't create system vm's with newer qemu-kvm-ev version), + RBD storage (ceph).

I tried to update qemu-kvm-ev to the newest version had the same results.

User avatar
TrevorH
Forum Moderator
Posts: 27138
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Libvirt 4.5.0-23 bug?

Post by TrevorH » 2019/11/21 09:28:11

Since it works for me on stock distro packages, I'd suggest that's what you use.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Arreth
Posts: 4
Joined: 2019/11/21 07:52:56

Re: Libvirt 4.5.0-23 bug?

Post by Arreth » 2019/11/22 07:17:54

There was an update today for libvirt-4.5.0-23.el7_6.3.x86_64 now there is: 4.5.0-23.el7_7.1 will try to check if it fixed my problem.

Arreth
Posts: 4
Joined: 2019/11/21 07:52:56

Re: Libvirt 4.5.0-23 bug?

Post by Arreth » 2019/11/26 15:08:37

Even with the updated libvirtd packages had the same outcome starting to think it's not libvirt problems

Post Reply

Return to “CentOS 7 - Software Support”