Mate screen lock issue

Issues related to applications and software problems
gostal
Posts: 30
Joined: 2019/09/23 15:26:45

Mate screen lock issue

Post by gostal » 2019/11/26 11:55:51

I'm using the Mate desktop and I can't get automatic screen locking to work. The only way to lock the screen is to go via System/Lock Screen.

I've tried various settings using gsettings and dconf-editor, logged out and back in, rebooted but so far no success. These are my current screen saver key settings (gsettings get org.mate.screensaver key):

Code: Select all

logout-enabled                  		false
lock-enabled                     		true
embedded-keyboard-enabled       		false
logout-delay                    		80
idle-activation-enabled         		true
themes                          		['screensavers-cosmos-slideshow']
logout-command                  		''
embedded-keyboard-command			''
mode						'single'
power-management-delay				30
lock-delay					15
cycle-delay					10
lock-dialog-theme				'default'
status-message-enabled				true
user-switch-enabled				true
Gnome 3 is also installed on the system. Can there be any interference?

Thanks for any help!

Cheers,
gostal
Desktop Dell T5810 Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz, 72 GB RAM, Radeon Pro WX 7100
CentOS 7.7.1908

User avatar
TrevorH
Forum Moderator
Posts: 27156
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Mate screen lock issue

Post by TrevorH » 2019/11/26 16:11:55

You don't need to fiddle with settings like that. It's controlled from System->Preferences->Look and Feel->Screensaver where you can toggle check boxes and move a slider to set the timeout period.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

gostal
Posts: 30
Joined: 2019/09/23 15:26:45

Re: Mate screen lock issue

Post by gostal » 2019/11/26 17:13:54

TrevorH wrote:
2019/11/26 16:11:55
You don't need to fiddle with settings like that. It's controlled from System->Preferences->Look and Feel->Screensaver where you can toggle check boxes and move a slider to set the timeout period.
That was the first thing I tried. Doesn't work!
Desktop Dell T5810 Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz, 72 GB RAM, Radeon Pro WX 7100
CentOS 7.7.1908

User avatar
TrevorH
Forum Moderator
Posts: 27156
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Mate screen lock issue

Post by TrevorH » 2019/11/26 18:44:56

It works here. So what's different? I just use blank and I've also set the power saving options off the button at the bottom of that dialog.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

gostal
Posts: 30
Joined: 2019/09/23 15:26:45

Re: Mate screen lock issue

Post by gostal » 2019/11/26 19:38:25

TrevorH wrote:
2019/11/26 18:44:56
It works here. So what's different? I just use blank and I've also set the power saving options off the button at the bottom of that dialog.
I've got both lock screen when idle and power saving checked. Maybe they don't work together? The screen goes dark but doesn't get locked so I guess the power saving works. I'll try turning the power saving off and see if that makes any difference.
Desktop Dell T5810 Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz, 72 GB RAM, Radeon Pro WX 7100
CentOS 7.7.1908

User avatar
TrevorH
Forum Moderator
Posts: 27156
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Mate screen lock issue

Post by TrevorH » 2019/11/26 20:03:39

There are at least two options. The first is in the screensaver dialog itself and is adjusted with a slider, the 2nd is in power management off that where there are options like "Dim display when idle" and "Put display to sleep when inactive for...". If you set those two to go pop before the slilder bar version then the screen will go dark but the screen saver hasn't cut in so you can resume it without a password. You should set the power settings to the same or greater than the screensaver one.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

gostal
Posts: 30
Joined: 2019/09/23 15:26:45

Re: Mate screen lock issue

Post by gostal » 2019/11/27 11:52:20

I wasn't in front of my system when I answered last night and my memory wasn't accurate. I'm sorry about that. Please ignore what I wrote. Now I have the system in front of me and this is what I have:

The slider "Regard the computer as idle after:" is set at 2 minutes
Activate screensaver when computer is idle - checked
Lock screen when screen saver is active - checked

Power Management pop-up window:

On AC power tab:
Put computer to sleep...- Never
Put displays to sleep..-30 minutes
Dim display ...- not checked

General tab:
So far I haven't touched anything here so I image settings are default but better safe than sorry.
When the power button is pressed: Ask me
When the suspend button is pressed: Suspend
Under Notification Area the only thing checked is: Only display an icon when a battery is present

Some of the settings here are irrelevant as this is not a laptop and I hope they are therefore ignored.

Now I'll take my hands off the keyboard and wait for at least 2 minutes and see what happens if anything.
Desktop Dell T5810 Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz, 72 GB RAM, Radeon Pro WX 7100
CentOS 7.7.1908

gostal
Posts: 30
Joined: 2019/09/23 15:26:45

Re: Mate screen lock issue

Post by gostal » 2019/11/27 13:45:52

Now I have left the system untouched more than 2 minutes several times. First time was over lunch which was more than 30 minutes, the display sleep setting and as before the screen was dark but it was not locked. Second time I set a timer for 3 minutes and waited. Nothing at all happened. No screen saver, nothing.

It appears then that automatic start of the screen saver is broken somewhere under the hood. Probably the locking works if only the screensaver would start but it doesn't as it seems. What could prevent it?
Desktop Dell T5810 Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz, 72 GB RAM, Radeon Pro WX 7100
CentOS 7.7.1908

User avatar
TrevorH
Forum Moderator
Posts: 27156
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Mate screen lock issue

Post by TrevorH » 2019/11/27 15:17:53

Check your logs for clues perhaps. Start with /var/log/messages and secure and Xorg.*.log and see if there's anything there.

I use it all the time and it always works. The only time I've had problems with it is when the power "Dim" setting was set lower than the lock time. The screen would go dark, I would assume I needed to type my password to unlock it and do so automatically and press enter while the screen was still dark... only to discover the password dialog hadn't kicked in and I'd just posted my password online... :-(
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

gostal
Posts: 30
Joined: 2019/09/23 15:26:45

Re: Mate screen lock issue

Post by gostal » 2019/11/27 17:11:40

cat /var/log/messages | grep saver gives me:

Code: Select all

Nov 25 13:08:15 hostname org.mate.ScreenSaver: mate-screensaver: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Nov 25 13:10:12 hostname gnome-session: gnome-session-binary[9889]: WARNING: Application 'org.gnome.SettingsDaemon.ScreensaverProxy.desktop' killed by signal 15
Nov 25 13:10:12 hostname gnome-session-binary[9889]: WARNING: Application 'org.gnome.SettingsDaemon.ScreensaverProxy.desktop' killed by signal 15
but there is nothing from today.

cat /var/log/secure | grep saver gives me:

Code: Select all

Nov 27 10:53:52 hostname mate-screensaver-dialog: pam_sss(mate-screensaver:auth): authentication success; ...
Nov 27 17:36:43 hostname mate-screensaver-dialog: pam_sss(mate-screensaver:auth): authentication success; ...
for today. I have removed sensitive information.

cat /var/log/Xorg.*.log | grep screen gives me:

Code: Select all

[566229.918] (==) No screen section available. Using defaults.
[566229.918] (==) No monitor specified for screen "Default Screen Section".
[566230.340] (II) GLX: Initialized DRI2 GL provider for screen 0
[566230.341] (II) AMDGPU(0): Setting screen physical size to 1016 x 285
for *=1 and 2

No clues here as far as I can make out. I also ran rpm -Vv on mate-power-manager-1.16.2-2.el7.x86_64 and mate-screensaver-1.16.1-1.el7.x86_64 and they both checked clean.

Anything more I can do in terms of investigation?
Desktop Dell T5810 Intel(R) Xeon(R) CPU E5-1650 v4 @ 3.60GHz, 72 GB RAM, Radeon Pro WX 7100
CentOS 7.7.1908

Post Reply

Return to “CentOS 7 - Software Support”