Issues with SanDisk II?

Issues related to hardware problems
Posts: 4
Joined: 2017/09/14 07:27:51

Issues with SanDisk II?

Postby bvz » 2017/09/14 07:44:19


I am new to Centos (I am switching from Ubuntu because most of the software I use is released in rpm format and I am sick of trying to make it work with alien)

Back when I set up my machine (Dell t5500, dual 6 Core Xeon x5675, Nvidia 1050ti, 24GB RAM, Sandisk Ultra II, 500GB SSD) with Ubuntu (16.04 - Gnome), I couldn't get it to run more than about 20 minutes without it freezing up on me (and occasionally the window server dying). The symptom was that suddenly I would lose the ability to see any files. I could still cd through the file hierarchy, but no actual files would show up. Trying to run command line commands would fail because things like 'ls' just didn't exist anymore. 'pwd' still worked though, as did 'cd'.

I fought with it for about a week before I finally figured out that it was related to my SSD. Once I reinstalled onto a 1TB WD spinning platter, everything worked just fine. The same SSD drive worked perfectly on the same machine running Windows, so I'm not sure that it is a hardware defect.

Now that I am trying to switch to CentOS 7 I thought I would give the SSD another try. So I pulled my WD 1TB and put in the SSD and installed CentOS onto that. Sure enough, CentOS hangs within about 5 minutes (The first time the window server died and then slowly all of my open apps disappeared). I haven't had a moment to try to dig into any logs (and, frankly, I don't even know what to look for) but I thought I would ask here quickly anyway:

Is this something anyone has ever heard of? Linux just hates my SSD? Is there any general troubleshooting ideas that anyone can suggest? Unfortunately the system hangs pretty fast so it doesn't give me a whole lot of time to poke around before I have to hard-boot it.

I'm fairly technical, but still pretty new to administering Linux (I've only been running Ubuntu for about a month - though I use Linux at work every day for the past 15 years)


User avatar
Forum Moderator
Posts: 22590
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Issues with SanDisk II?

Postby TrevorH » 2017/09/14 10:15:04

What's the output from smartctl -a /dev/sda (adjust device name to point to the right one). Part of the smartmontools package so you may need to install that first.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 4
Joined: 2017/09/14 07:27:51

Re: Issues with SanDisk II?

Postby bvz » 2017/09/17 22:45:47

Thanks for the reply (both here and on my other post)! (I apparently do not have auto-subscribe turned on so I only saw this now).

I will run this command again, (I ran a smart test on it under Ubuntu a month ago and it passed) but I seem to have "solved" the issue.

Having given up my my SSD, I installed a regular hard drive and tried to install CentOS on that. The install failed part way through with a disk error of some kind.

Previously, under Ubuntu, the SSD would fail as well but I then noticed that when Ubuntu ran and was stable was when I had installed in on my second drive which was plugged into a different SATA port. So, as a test, I took SSD and plugged it into that same SATA port and suddenly everything became quick and stable. I have been running without an issue since then.

I'll keep an eye on it with the smart tools, but I think it was an issue with the port (whether it is just a bad cable, bad port, or some mis-configuration I don't know... this was a used computer I picked up for cheap so anything could be wrong with it). For now everything is back on track.

Thanks again for the quick reply!