AMD fglrx not working under centos 7.3

Issues related to hardware problems
hunter86_bg
Posts: 803
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: AMD fglrx not working under centos 7.3

Postby hunter86_bg » 2017/10/10 10:38:17

Have you rebuild the initramfs ?
Of course booting from older kernel and reinstalling the latest one makes the same thing ...

kb9mfd
Posts: 9
Joined: 2011/12/13 13:17:56

Re: AMD fglrx not working under centos 7.3

Postby kb9mfd » 2017/10/10 11:46:58

hunter86_bg wrote:Have you rebuild the initramfs ?
Of course booting from older kernel and reinstalling the latest one makes the same thing ...


I thought installing the kmod-fglrx package did that. I guess I can try it manually, but according to the X log it appears the error is a symbol issue between the driver and the X version. As for loading the later version (15.12-6) rpm is giving we a weird depenancy error I am not familiar with. Is there a place to download the driver source to compile a copy?

User avatar
TrevorH
Forum Moderator
Posts: 21170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: AMD fglrx not working under centos 7.3

Postby TrevorH » 2017/10/10 12:27:24

I'm not sure that the current fglrx packages support 7.4 at all. You might want to ask on #elrepo on freenode IRC or on the ELRepo mailing list about the current status. As I understand it, fglrx is no longer maintained by AMD and the newer driver, amdgpu, is not (yet) packaged by ELRepo.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

hunter86_bg
Posts: 803
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: AMD fglrx not working under centos 7.3

Postby hunter86_bg » 2017/10/10 12:28:11

My previous message was related to a 'rollback'.