CentOS7 installer fails to see HDDs [SOLVED]

Issues related to hardware problems
Posts: 1
Joined: 2014/10/17 17:48:12

CentOS7 installer fails to see HDDs [SOLVED]

Postby Daniel.Morrison » 2014/10/17 18:44:34

Long-time CentOS adminstrator, but this is my first foray into the forums.

I have a set of ~6-year old server systems with Intel S5400SF motherboard and matching 1U chassis. They take three SATA drives. They ran CentOS-5 for ages, but are getting an upgrade now to CentOS-7 and new (recycled) hard drives.

The new CentOS 7 installer (which is very nice otherwise) completely ignores the drives I have put in. They simply do not show up in the 'Local Standard Disks' section of Device Selection.

I also tried wiping the first 40 MB or so with 'dd if=/dev/zero', just to make sure there was no weird data on the disk to confuse the CentOS installer (the drives were previously running CentOS-5 on a Dell PowerEdge with hardware RAID). Didn't help.

I tried booting the CentOS-6 installer (64-bit). It helpfully told me that /dev/sdb and /dev/sdc contained residual "BIOS RAID metadata" and so was ignoring these drives. Turns out this metadata is stored at the END of the disk, so my wipe of the first 40 MB was fruitless. Removing this metadata is a pain in the neck:

http://unix.stackexchange.com/questions ... ntaining-b
dmraid -r -E /dev/sdb
Do you really want to earse "ddf1" ondisk metadata on /dev/sdb ? [y/n] :y

http://kb.seflow.it/article/how-to-remo ... ta-26.html
dd if=/dev/zero of=/dev/sda bs=1024 seek=(<blocks>-20) count=20

Note: <blocks> is the TOTAL number of bytes on the disk, divided by 1024. The number of blocks in a single, whole-disk partition is NOT the right number. You must wipe the 20 last kB of the DISK, not of the PARTITION.

I think it's pretty silly that the CentOS-6 installer ignores drives like these without giving the option to "use anyway". But AT LEAST it prints a message about it. The CentOS 7 installer simply silently fails, which is not friendly; it has cost me a lot of time on this project!

Below is other stuff I tried before I figured it out.



I have tried booting with SATA -> AHCI mode, and with SATA in 'Legacy' mode, and with AHCI turned off altogether, I have upgraded the system BIOS. It makes no difference.

The drives appear in /proc/scsi/scsi, and I can run fdisk on them; I made an md RAID1 and an LVM volume group on them while in the installer environment. They behave perfectly normally. But I cannot install on them because the GUI installer won't show them. (I tried booting the installer in 'text' mode also, same problem).

The drives are very ordinary Seagate Barracuda ES 750 GB hard disks. ST3750640NS.

If I insert a different hard drive at the same time, e.g. /dev/sda -> ST2000DL003, or even something different (I tried an OCZ Agility 2 SSD), these show up just fine and the installer wants to use them. At the SAME TIME as the ES drives are not shown at all, despite being accessible as /dev/sdb and /dev/sdc.

All the online searches I perform for 'HDD not detected' return cases where users had a specialty SATA/RAID card, and special drivers or parameters were required to detect the controller card. This is not the case here. The drives are plugged directly into the motherboard's SATA ports, and as I said, the kernel detects them no problem.

Posts: 2
Joined: 2015/11/28 09:44:14

Re: CentOS7 installer fails to see HDDs [SOLVED]

Postby strasharo » 2015/11/28 10:12:33

Just hit exactly the same issue. Thanks a lot for the provided solution and sparing me the time needed to dd the whole 1T disk. :lol:

Posts: 2
Joined: 2015/11/28 09:44:14

Re: CentOS7 installer fails to see HDDs [SOLVED]

Postby strasharo » 2015/11/28 10:27:25

Posts: 2
Joined: 2015/09/26 14:05:43

Re: CentOS7 installer fails to see HDDs [SOLVED]

Postby jacquesbezuidenhout » 2017/01/08 16:47:32

Hi Guys,

thanks, this led me halfway to the solution. in centos 7.3 installer, i had the same problem. the above solution did not work.

i want to reference the following: https://raid.wiki.kernel.org/index.php/ ... ck_formats

i used "version-0.90 Superblock Format" in a raid 1 array.

and i quote: "The superblock is 4K long and is written into a 64K aligned block that starts at least 64K and less than 128K from the end of the device"

so to make it easy, i took my drive size / 1024, and then minus 128, let's call it <newsize>, so the above command changes slightly to

dd if=/dev/zero of=/dev/sdb bs=1024 seek=<newsize> count=128

if completely unsure, write like 10MB from the start, and 10MB at the end following the above :lol: it should save you writing over the whole hard drive.

Posts: 1
Joined: 2017/08/26 14:58:45

Re: CentOS7 installer fails to see HDDs [SOLVED]

Postby yves.vogl » 2017/08/26 14:59:41

wipefs -af <device> is the right way to solve this.

Posts: 1
Joined: 2018/02/11 04:13:34

Re: CentOS7 installer fails to see HDDs [SOLVED]

Postby ajcpominoz » 2018/02/24 10:09:06

So an erase and repartition will not fix this?
I’ll just do 1 pass. Can’t be bothered.