Page 3 of 3

Re: AMD fglrx not working under centos 7.3

Posted: 2017/10/10 10:38:17
by hunter86_bg
Have you rebuild the initramfs ?
Of course booting from older kernel and reinstalling the latest one makes the same thing ...

Re: AMD fglrx not working under centos 7.3

Posted: 2017/10/10 11:46:58
by kb9mfd
hunter86_bg wrote:Have you rebuild the initramfs ?
Of course booting from older kernel and reinstalling the latest one makes the same thing ...


I thought installing the kmod-fglrx package did that. I guess I can try it manually, but according to the X log it appears the error is a symbol issue between the driver and the X version. As for loading the later version (15.12-6) rpm is giving we a weird depenancy error I am not familiar with. Is there a place to download the driver source to compile a copy?

Re: AMD fglrx not working under centos 7.3

Posted: 2017/10/10 12:27:24
by TrevorH
I'm not sure that the current fglrx packages support 7.4 at all. You might want to ask on #elrepo on freenode IRC or on the ELRepo mailing list about the current status. As I understand it, fglrx is no longer maintained by AMD and the newer driver, amdgpu, is not (yet) packaged by ELRepo.

Re: AMD fglrx not working under centos 7.3

Posted: 2017/10/10 12:28:11
by hunter86_bg
My previous message was related to a 'rollback'.