Sporadic reboots w/CentOS 7 on Compaq ML110 G4

Issues related to hardware problems
bkamen
Posts: 29
Joined: 2009/12/06 20:48:46
Location: Central Illinois, USA

Sporadic reboots w/CentOS 7 on Compaq ML110 G4

Postby bkamen » 2017/07/10 18:31:25

Hey all,

I'm having weird issues with 7 on an older Compaq ML110 G4.

Other specialty/installed hardware is:

* Intel Core Q6700 @ 2.66GHz
* (4) 2GB DDR2-PC5300 RAM (per spec)
* Nvidia GT710 PCIe x8
* Intel 2x1G 82546 PCI-X Ethernet controller in 32bit PCI slot


I thought it was a memory issue (and it might be) -- I was seeing lots of EDAC log messages... so I pulled out 1/2 the RAM populating the correct slots per the user manual. (DIMM1/3)

ok -- no more EDAC messages... but the system keeps randomly rebooting.

IPMI watchdogs are disabled.

MemTest 86+ runs for DAYS with no problem.
Currently running PartitionMagic from UltimateBootCD to just sit and spin (which I've done when testing the HDisks I stuffed into this system -- for DAYS) with no problem.

Can't seem to get past 6-7hours of uptime before random reboots.

What can I post to help determine what to go look for?

Thanks,

-Ben

bkamen
Posts: 29
Joined: 2009/12/06 20:48:46
Location: Central Illinois, USA

Re: Sporadic reboots w/CentOS 7 on Compaq ML110 G4

Postby bkamen » 2017/07/10 18:37:22

I should note, with this hardware same config (minus the video card) I ran OpenMediaVault on the system for months and didn't seem to have a problem.

-Ben

Boyd.ako
Posts: 15
Joined: 2016/06/22 08:49:07
Location: Honolulu, HI
Contact:

Re: Sporadic reboots w/CentOS 7 on Compaq ML110 G4

Postby Boyd.ako » 2017/09/01 03:27:24

Can you clear the DMESG output or the /var/log/messages and then post the output after it happens again?

Normally the precursor will have something in there to lead you. What kind of "special" software you got running on the system? Normally this type of stuff happens due to memory overflows. Also, what kind of memory are you using? If you're mixing ECC/EDAC memory with those that are not then that could be the issue when it tries to review or correct any errors.
My noob level: LPIC-2, Sec+ CE, Linux+