CentOS EL7.4 wifi broadcom problem

Issues related to hardware problems
ag1988
Posts: 3
Joined: 2017/12/20 16:03:29

CentOS EL7.4 wifi broadcom problem

Postby ag1988 » 2017/12/20 17:04:00

Hello,
I have been using linux for a week.
I installed CentOS EL7.4 on my laptop HP 6735S (AMD Athlon X2 QL-60 1.9 GHz/2Gb/Radeon3200/wifi Brodacom 4312)
Details https://support.hp.com/ru-ru/product/hp ... /c01527043
My problem is non-working wi-fi adapter.
I tried to use HowTo from centos Wiki https://wiki.centos.org/HowTos/Laptops/ ... s/Broadcom . But it isn't works correectly.
I done compilation succesfully, but after command

Code: Select all

modprobe wl
my laptop switched on capsLock and freezed (laptop isn't reacts to any manipulation).

Also i saved all terminal outputs in file and i can attach if it's necessary.

Thank you.

User avatar
TrevorH
Forum Moderator
Posts: 21742
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS EL7.4 wifi broadcom problem

Postby TrevorH » 2017/12/20 17:32:31

Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

ag1988
Posts: 3
Joined: 2017/12/20 16:03:29

Re: CentOS EL7.4 wifi broadcom problem

Postby ag1988 » 2017/12/20 19:59:31

TrevorH wrote:Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.

I used centos wiki page itself and elrepo wiki page both.
    1. I used centos wiki and got a laptot freezing.
    2. I tried to used elrepo wiki and I stopped at paragraph 5. Namely a command

    Code: Select all

    $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
    gave an error. Also i didn't understand what is mean the ellipsis in code below

    Code: Select all

       $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
       ...
       Wrote: /home/<user>/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm
       ...
       + exit 0

    3. I used centos wiki and got a laptot freezing second time.
    4. I decided to go to CentOS forum)

So, I suppose better way is to use elrepo solution one more time and to describe here appearing error. Is it correct?

P.S.
I've put my problem in forum thread "CentOS 6 - Hardware Support". I suppose more correctly shoul be "CentOS 7 - Hardware Support". Is it possible to to move it?

ag1988
Posts: 3
Joined: 2017/12/20 16:03:29

Re: CentOS EL7.4 wifi broadcom problem

Postby ag1988 » 2017/12/21 03:23:25

TrevorH wrote:Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.


Thanks, elrepo method is works. My inexperience is the reason of first failure with elrepo.
Nevertheless if I turn on airplane mode and than turn off it than my laptop is freeze. So it is insignificantly.

So I suppose the question is closed.

dungta0321
Posts: 1
Joined: 2017/12/31 00:50:09

Re: CentOS EL7.4 wifi broadcom problem

Postby dungta0321 » 2017/12/31 01:42:42

ag1988 wrote:
TrevorH wrote:Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.

I used centos wiki page itself and elrepo wiki page both.
    1. I used centos wiki and got a laptot freezing.
    2. I tried to used elrepo wiki and I stopped at paragraph 5. Namely a command

    Code: Select all

    $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
    gave an error. Also i didn't understand what is mean the ellipsis in code below

    Code: Select all

       $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
       ...
       Wrote: /home/<user>/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm
       ...
       + exit 0

    3. I used centos wiki and got a laptot freezing second time.
    4. I decided to go to CentOS forum)

So, I suppose better way is to use elrepo solution one more time and to describe here appearing error. Is it correct?

P.S.
I've put my problem in forum thread "CentOS 6 - Hardware Support". I suppose more correctly shoul be "CentOS 7 - Hardware Support". Is it possible to to move it?

Hi, I don't understan the paragraph 5 too, could you explain it to me, thanks

User avatar
TrevorH
Forum Moderator
Posts: 21742
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS EL7.4 wifi broadcom problem

Postby TrevorH » 2017/12/31 14:09:12

You should substitute your own values for anything in the supplied commands where data is enclosed in <this> - e.g. "--define 'packager <your-name>" should be "--define 'packager my.email@company.com". Similarly <path-to-nosrc.rpm> should be the actual path to your downloaded nosrc.rpm package. Do not include < or > symbols in your command as they will be interpreted as redirection symbls by the shell you run.

The places where there are lines in the sample output containing ellipsis (...) mean that you can expect many many lines of output here and they have been removed from the sample as they're not important (when they work!).
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke