CentOS EL7.4 wifi broadcom problem

Issues related to hardware problems
ag1988
Posts: 3
Joined: 2017/12/20 16:03:29

CentOS EL7.4 wifi broadcom problem

Postby ag1988 » 2017/12/20 17:04:00

Hello,
I have been using linux for a week.
I installed CentOS EL7.4 on my laptop HP 6735S (AMD Athlon X2 QL-60 1.9 GHz/2Gb/Radeon3200/wifi Brodacom 4312)
Details https://support.hp.com/ru-ru/product/hp ... /c01527043
My problem is non-working wi-fi adapter.
I tried to use HowTo from centos Wiki https://wiki.centos.org/HowTos/Laptops/ ... s/Broadcom . But it isn't works correectly.
I done compilation succesfully, but after command

Code: Select all

modprobe wl
my laptop switched on capsLock and freezed (laptop isn't reacts to any manipulation).

Also i saved all terminal outputs in file and i can attach if it's necessary.

Thank you.

User avatar
TrevorH
Forum Moderator
Posts: 22285
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS EL7.4 wifi broadcom problem

Postby TrevorH » 2017/12/20 17:32:31

Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

ag1988
Posts: 3
Joined: 2017/12/20 16:03:29

Re: CentOS EL7.4 wifi broadcom problem

Postby ag1988 » 2017/12/20 19:59:31

TrevorH wrote:Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.

I used centos wiki page itself and elrepo wiki page both.
    1. I used centos wiki and got a laptot freezing.
    2. I tried to used elrepo wiki and I stopped at paragraph 5. Namely a command

    Code: Select all

    $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
    gave an error. Also i didn't understand what is mean the ellipsis in code below

    Code: Select all

       $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
       ...
       Wrote: /home/<user>/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm
       ...
       + exit 0

    3. I used centos wiki and got a laptot freezing second time.
    4. I decided to go to CentOS forum)

So, I suppose better way is to use elrepo solution one more time and to describe here appearing error. Is it correct?

P.S.
I've put my problem in forum thread "CentOS 6 - Hardware Support". I suppose more correctly shoul be "CentOS 7 - Hardware Support". Is it possible to to move it?

ag1988
Posts: 3
Joined: 2017/12/20 16:03:29

Re: CentOS EL7.4 wifi broadcom problem

Postby ag1988 » 2017/12/21 03:23:25

TrevorH wrote:Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.


Thanks, elrepo method is works. My inexperience is the reason of first failure with elrepo.
Nevertheless if I turn on airplane mode and than turn off it than my laptop is freeze. So it is insignificantly.

So I suppose the question is closed.

dungta0321
Posts: 1
Joined: 2017/12/31 00:50:09

Re: CentOS EL7.4 wifi broadcom problem

Postby dungta0321 » 2017/12/31 01:42:42

ag1988 wrote:
TrevorH wrote:Did you use the CentOS wiki page itself or the link to the more recent instructions on http://elrepo.org/tiki/wl-kmod ? The latter is recommended.

I used centos wiki page itself and elrepo wiki page both.
    1. I used centos wiki and got a laptot freezing.
    2. I tried to used elrepo wiki and I stopped at paragraph 5. Namely a command

    Code: Select all

    $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
    gave an error. Also i didn't understand what is mean the ellipsis in code below

    Code: Select all

       $ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
       ...
       Wrote: /home/<user>/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm
       ...
       + exit 0

    3. I used centos wiki and got a laptot freezing second time.
    4. I decided to go to CentOS forum)

So, I suppose better way is to use elrepo solution one more time and to describe here appearing error. Is it correct?

P.S.
I've put my problem in forum thread "CentOS 6 - Hardware Support". I suppose more correctly shoul be "CentOS 7 - Hardware Support". Is it possible to to move it?

Hi, I don't understan the paragraph 5 too, could you explain it to me, thanks

User avatar
TrevorH
Forum Moderator
Posts: 22285
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS EL7.4 wifi broadcom problem

Postby TrevorH » 2017/12/31 14:09:12

You should substitute your own values for anything in the supplied commands where data is enclosed in <this> - e.g. "--define 'packager <your-name>" should be "--define 'packager my.email@company.com". Similarly <path-to-nosrc.rpm> should be the actual path to your downloaded nosrc.rpm package. Do not include < or > symbols in your command as they will be interpreted as redirection symbls by the shell you run.

The places where there are lines in the sample output containing ellipsis (...) mean that you can expect many many lines of output here and they have been removed from the sample as they're not important (when they work!).
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

m0naLisa
Posts: 3
Joined: 2018/03/19 02:52:04

Re: CentOS EL7.4 wifi broadcom problem

Postby m0naLisa » 2018/03/19 16:00:38

TrevorH wrote:You should substitute your own values for anything in the supplied commands where data is enclosed in <this> - e.g. "--define 'packager <your-name>" should be "--define 'packager my.email@company.com". Similarly <path-to-nosrc.rpm> should be the actual path to your downloaded nosrc.rpm package. Do not include < or > symbols in your command as they will be interpreted as redirection symbls by the shell you run.

The places where there are lines in the sample output containing ellipsis (...) mean that you can expect many many lines of output here and they have been removed from the sample as they're not important (when they work!).





Original
$ rpmbuild --rebuild --define 'packager <your-name>' /<path-to-nosrc.rpm>/wl-kmod*nosrc.rpm
...
Wrote: /home/<user>/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm
...
+ exit 0

Me
$ rpmbuild --rebuild --define 'packager Sistemas-Dif' /home/Sistemas-Dif/Downloads/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm
...
Wrote: /home/Sistemas-Dif/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm
...
+ exit 0

I'm stuck in this part could you explain me step by step please :rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm

im New in Linux Thank You

User avatar
TrevorH
Forum Moderator
Posts: 22285
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS EL7.4 wifi broadcom problem

Postby TrevorH » 2018/03/19 16:04:51

I don't understand your question. When you ran rpmbuild it will have generated a lot of output and towards the end of that output you should see something like

Wrote: /home/Sistemas-Dif/rpmbuild/RPMS/x86_64/kmod-wl-<version>.x86_64.rpm

but <version> should be the same as the version on the src rpm you rebuilt.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

m0naLisa
Posts: 3
Joined: 2018/03/19 02:52:04

Re: CentOS EL7.4 wifi broadcom problem

Postby m0naLisa » 2018/03/19 18:26:42

[Sistemas-Dif@localhost ~]$ rpmbuild --rebuild --define 'packager Sistemas-Dif' /home/Sistemas-Dif/Descargas/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm
Instalando /home/Sistemas-Dif/Descargas/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm
advertencia:usuario tindall no existe - utilizando root
advertencia:grupo tindall no existe - utilizando root
advertencia:usuario tindall no existe - utilizando root
advertencia:grupo tindall no existe - utilizando root
advertencia:usuario tindall no existe - utilizando root
advertencia:grupo tindall no existe - utilizando root
advertencia:usuario tindall no existe - utilizando root
advertencia:grupo tindall no existe - utilizando root
advertencia:usuario tindall no existe - utilizando root
advertencia:grupo tindall no existe - utilizando root
advertencia:usuario tindall no existe - utilizando root
advertencia:grupo tindall no existe - utilizando root
ls: no se puede acceder a /usr/src/kernels/4.15.10-1.el7*.elrepo.x86_64: No existe el fichero o el directorio
Ejecutando(%prep): /bin/sh -e /var/tmp/rpm-tmp.xezi0h
+ umask 022
+ cd /home/Sistemas-Dif/rpmbuild/BUILD
+ cd /home/Sistemas-Dif/rpmbuild/BUILD
+ rm -rf wl-kmod-6_30_223_271
+ /usr/bin/mkdir -p wl-kmod-6_30_223_271
+ cd wl-kmod-6_30_223_271
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ cd /home/Sistemas-Dif/rpmbuild/BUILD
+ cd wl-kmod-6_30_223_271
+ /usr/bin/tar -xf -
+ /usr/bin/gzip -dc /home/Sistemas-Dif/rpmbuild/SOURCES/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ echo 'Patch #0 (wl-kmod-fix-ioctl-handling.patch):'
Patch #0 (wl-kmod-fix-ioctl-handling.patch):
+ /usr/bin/cat /home/Sistemas-Dif/rpmbuild/SOURCES/wl-kmod-fix-ioctl-handling.patch
+ /usr/bin/patch -p1 --fuzz=0
patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 1467 (offset 17 lines).
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 1659 (offset 8 lines).
+ echo 'Patch #1 (wl-kmod-01_kernel_4.7_IEEE80211_BAND_to_NL80211_BAND.patch):'
Patch #1 (wl-kmod-01_kernel_4.7_IEEE80211_BAND_to_NL80211_BAND.patch):
+ /usr/bin/cat /home/Sistemas-Dif/rpmbuild/SOURCES/wl-kmod-01_kernel_4.7_IEEE80211_BAND_to_NL80211_BAND.patch
+ /usr/bin/patch -p1 --fuzz=0
patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #6 succeeded at 1911 (offset 3 lines).
Hunk #7 succeeded at 2040 (offset 3 lines).
Hunk #8 succeeded at 2160 (offset 3 lines).
Hunk #9 succeeded at 2298 (offset 3 lines).
Hunk #10 succeeded at 2941 (offset 3 lines).
+ echo 'Patch #2 (wl-kmod-02_kernel_4.8_add_cfg80211_scan_info_struct.patch):'
Patch #2 (wl-kmod-02_kernel_4.8_add_cfg80211_scan_info_struct.patch):
+ /usr/bin/patch -p1 --fuzz=0
+ /usr/bin/cat /home/Sistemas-Dif/rpmbuild/SOURCES/wl-kmod-02_kernel_4.8_add_cfg80211_scan_info_struct.patch
patching file src/wl/sys/wl_cfg80211_hybrid.c
Hunk #1 succeeded at 2442 (offset 3 lines).
Hunk #2 succeeded at 2553 (offset 3 lines).
Hunk #3 succeeded at 2989 (offset 3 lines).
+ echo 'This specification file has been written for use with RHEL 7 kernels only.'
This specification file has been written for use with RHEL 7 kernels only.
+ false
error: Estado de salida erróneo de /var/tmp/rpm-tmp.xezi0h (%prep)


Errores de construcción RPM:
usuario tindall no existe - utilizando root
grupo tindall no existe - utilizando root
usuario tindall no existe - utilizando root
grupo tindall no existe - utilizando root
usuario tindall no existe - utilizando root
grupo tindall no existe - utilizando root
usuario tindall no existe - utilizando root
grupo tindall no existe - utilizando root
usuario tindall no existe - utilizando root
grupo tindall no existe - utilizando root
usuario tindall no existe - utilizando root
grupo tindall no existe - utilizando root
Estado de salida erróneo de /var/tmp/rpm-tmp.xezi0h (%prep)
[Sistemas-Dif@localhost ~]$



I do not know if I did it right I think I'm missing something because it says that user and tindall group does not exist
help please


[Sistemas-Dif@localhost ~]$ uname -r
4.15.10-1.el7.elrepo.x86_64
Last edited by m0naLisa on 2018/03/19 19:51:06, edited 1 time in total.

User avatar
WhatsHisName
Posts: 1539
Joined: 2005/12/19 20:21:43
Location: /earth/usa/nj

Re: CentOS EL7.4 wifi broadcom problem

Postby WhatsHisName » 2018/03/19 18:57:36

m0naLisa wrote:[Sistemas-Dif@localhost ~]$ rpmbuild --rebuild --define 'packager Sistemas-Dif' /home/Sistemas-Dif/Descargas/wl-kmod-6_30_223_271-4.el7.elrepo.nosrc.rpm
...
advertencia:grupo tindall no existe - utilizando root
ls: no se puede acceder a /usr/src/kernels/4.15.10-1.el7*.elrepo.x86_64: No existe el fichero o el directorio
Ejecutando(%prep): /bin/sh -e /var/tmp/rpm-tmp.xezi0h
...
+ echo 'This specification file has been written for use with RHEL 7 kernels only.'
This specification file has been written for use with RHEL 7 kernels only.
+ false


You are not using a stock EL7 kernel for the build.

Please post the output for "uname -r".

You can only build kmod-wl from the srpm using a standard EL7 kernel (e.g., 3.10.0-693.21.1.el7.x86_64) and the resulting kmod-wl will only function with stock kernels in the same series.