Speaker sound stopped

Issues related to hardware problems
Post Reply
dafh
Posts: 5
Joined: 2016/11/07 22:14:32

Speaker sound stopped

Post by dafh » 2017/12/24 05:22:18

Hi everyone!

I was working on my Dell Inspiron 14 with CentOS Linux release 7.4.1708 (Core) and the speaker sound suddenly stopped (it asked me to update the system, but it stopped before I did it). With headphones there is no issue, so this is related to the hardware I think, but I don't know how to proceed. Some basic information:

lspci -nn | grep Audio

00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)

lsmod | grep snd

snd_hda_codec_hdmi 47938 1
snd_hda_codec_realtek 92355 1
snd_hda_codec_generic 73789 1 snd_hda_codec_realtek
snd_hda_intel 39938 9
snd_hda_codec 137153 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_soc_rt5640 118324 0
snd_soc_rl6231 13321 1 snd_soc_rt5640
snd_soc_core 229807 1 snd_soc_rt5640
snd_hda_core 85885 5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_compress 19637 1 snd_soc_core
snd_hwdep 13608 1 snd_hda_codec
snd_seq 62699 0
snd_seq_device 14356 1 snd_seq
snd_pcm 106416 7 snd_soc_rt5640,snd_soc_core,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
regmap_i2c 12915 1 snd_soc_rt5640
snd_timer 29822 2 snd_pcm,snd_seq
snd_soc_sst_acpi 12858 0
snd 83383 29 snd_hda_codec_realtek,snd_soc_core,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_compress
soundcore 15047 1 snd
snd_soc_sst_match 13186 1 snd_soc_sst_acpi
i2c_core 40756 10 drm,i915,i2c_i801,snd_soc_rt5640,i2c_designware_core,i2c_designware_platform,regmap_i2c,drm_kms_helper,i2c_algo_bit,videodev

If you have any idea please share, I really hope it is not related to the motherboard :/

Thanks in advance

dafh
Posts: 5
Joined: 2016/11/07 22:14:32

Re: Speaker sound stopped

Post by dafh » 2017/12/24 18:18:34

Hi,

After a shutdown for ~ 8 hours, the audio came back. I'm still unsure why this happened in the first place.

George99
Posts: 26
Joined: 2013/09/08 17:01:05
Location: Germany

Re: Speaker sound stopped

Post by George99 » 2017/12/24 21:17:44

If there were no sound problem while using the headphones (connected to the audio jack I suppose) it would assume a hardware malfunction of the internal speaker.

dafh
Posts: 5
Joined: 2016/11/07 22:14:32

Re: Speaker sound stopped

Post by dafh » 2017/12/27 00:23:23

Yes, that was I was afraid of. This is almost surely a hardware malfunction. Thanks George99.

Post Reply