Startech Serial card PEX8S952 not detecting all ports

Issues related to hardware problems
Post Reply
erul
Posts: 4
Joined: 2018/01/08 15:56:28

Startech Serial card PEX8S952 not detecting all ports

Post by erul » 2018/01/08 16:19:50

Hello!

I purchased a Startech Pex8S952 which uses the OXPCIe958 controller and is compatible with Linux.
https://www.startech.com/eu/Cards-Adapt ... T~PEX8S952
Centos only detects four out of the eight serial ports on the card and names them ttyS0 - 3.
I'm getting some strange output from dmesg during the boot process:

Code: Select all

 2.643663] EDAC MC: Ver: 3.0.0
[    2.644132] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042f conflicts with OpRegion 0x0000000000000400-0x000000000000047f (\PMIO) (20130517/utaddress-254)
[    2.644138] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    2.644141] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054f conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20130517/utaddress-254)
[    2.644144] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    2.644942] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053f conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20130517/utaddress-254)
[    2.644947] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    2.644949] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052f conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20130517/utaddress-254)
[    2.644952] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    2.644953] lpc_ich: Resource conflict(s) found affecting gpio_ich
[    2.645146] EDAC MC0: Giving out device to 'ie31200_edac' 'IE31200': DEV 0000:00:00.0
Any idea what's wrong? It works fine in FreeBSD and Windows but this particular machine needs to run Centos 7.
Thank you

/e

User avatar
TrevorH
Forum Moderator
Posts: 23680
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Startech Serial card PEX8S952 not detecting all ports

Post by TrevorH » 2018/01/08 16:57:31

Try appending 8250.nr_uarts=8 to your kernel command line.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

erul
Posts: 4
Joined: 2018/01/08 15:56:28

Re: Startech Serial card PEX8S952 not detecting all ports

Post by erul » 2018/01/08 18:34:44

TrevorH wrote:Try appending 8250.nr_uarts=8 to your kernel command line.
Thanks, I tried this just before i left work; No luck. All eight ttyS showed up but none of them worked, will continue tomorrow.

erul
Posts: 4
Joined: 2018/01/08 15:56:28

Re: Startech Serial card PEX8S952 not detecting all ports

Post by erul » 2018/01/09 11:04:32

All ttys appear now.


[root@oob1 oob]# ls /dev/ttyS*
/dev/ttyS0 /dev/ttyS1 /dev/ttyS2 /dev/ttyS3 /dev/ttyS4 /dev/ttyS5 /dev/ttyS6 /dev/ttyS7

I have disabled the two built in serial ports on the motherboard to simplify troubleshooting. Any ideas what to try next?
Here's my output from setserial.

[root@oob1 oob]# setserial -g /dev/ttyS*
/dev/ttyS0, UART: unknown, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: unknown, Port: 0x02f8, IRQ: 3
/dev/ttyS2, UART: 16550A, Port: 0x03e8, IRQ: 10
/dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
/dev/ttyS4, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS5, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS6, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS7, UART: unknown, Port: 0x0000, IRQ: 0

erul
Posts: 4
Joined: 2018/01/08 15:56:28

Re: Startech Serial card PEX8S952 not detecting all ports

Post by erul » 2018/01/11 12:03:00

Solved:
If anyone else finds this thread, try reseting BIOS to default settings and allocate more uarts in the kernel parameter than you think you need. My supermicro had some hidden COM ports that i did not know of.

/e

Post Reply