Geforce 1050ti Driver issues.

Issues related to hardware problems
supertight
Posts: 167
Joined: 2017/02/07 21:47:51

Geforce 1050ti Driver issues.

Postby supertight » 2018/01/11 13:35:51

I have a fresh install of GNOME desktop & dev tools. I'm attempting to install MSI Geforce1050 ti video card. I'm attempting to load the drivers via Elrepo.
I keep getting this error. I've tried a bunch of google-fu. I'm getting nowhere.
Can someone please point me in the correct direction. Thank you.

Code: Select all

Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : yum-plugin-nvidia-1.0.2-1.el7.elrepo.noarch                  1/3
  Installing : kmod-nvidia-384.111-1.el7_4.elrepo.x86_64                    2/3

Broadcast message from systemd-journald@localhost.localdomain (Thu 2018-01-11 06:29:14 MST):

dracut[14000]: dracut: creation of /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp failed


Message from syslogd@localhost at Jan 11 06:29:14 ...
 dracut:dracut: creation of /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp failed

Broadcast message from systemd-journald@localhost.localdomain (Thu 2018-01-11 06:30:15 MST):

dracut[27601]: dracut: creation of /boot/initramfs-3.10.0-693.el7.x86_64.tmp failed


Message from syslogd@localhost at Jan 11 06:30:15 ...
 dracut:dracut: creation of /boot/initramfs-3.10.0-693.el7.x86_64.tmp failed
Working. This may take some time ...
cp: error writing '/boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp': No space left on device
cp: failed to extend '/boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp': No space left on device
dracut: creation of /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp failed
/sbin/weak-modules: line 132: /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp: No such file or directory
/sbin/weak-modules: line 148: /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp: No such file or directory
/sbin/weak-modules: line 153: /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp: No such file or directory
Unable to decompress /boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp: Unknown format
/sbin/weak-modules: line 191: /tmp/weak-modules.BppF07/new_initramfs.img: No such file or directory
rm: cannot remove '/tmp/weak-modules.BppF07/new_initramfs.img': No such file or directory
mv: cannot stat '/boot/initramfs-3.10.0-693.11.6.el7.x86_64.tmp': No such file or directory
cp: error writing '/boot/initramfs-3.10.0-693.el7.x86_64.tmp': No space left on device
cp: failed to extend '/boot/initramfs-3.10.0-693.el7.x86_64.tmp': No space left on device
dracut: creation of /boot/initramfs-3.10.0-693.el7.x86_64.tmp failed
/sbin/weak-modules: line 132: /boot/initramfs-3.10.0-693.el7.x86_64.tmp: No such file or directory
/sbin/weak-modules: line 148: /boot/initramfs-3.10.0-693.el7.x86_64.tmp: No such file or directory
/sbin/weak-modules: line 153: /boot/initramfs-3.10.0-693.el7.x86_64.tmp: No such file or directory
Unable to decompress /boot/initramfs-3.10.0-693.el7.x86_64.tmp: Unknown format
/sbin/weak-modules: line 191: /tmp/weak-modules.BppF07/new_initramfs.img: No such file or directory
rm: cannot remove '/tmp/weak-modules.BppF07/new_initramfs.img': No such file or directory
mv: cannot stat '/boot/initramfs-3.10.0-693.el7.x86_64.tmp': No such file or directory
Done.

stevemowbray
Posts: 367
Joined: 2012/06/26 14:20:47

Re: Geforce 1050ti Driver issues.

Postby stevemowbray » 2018/01/11 13:41:45

Your /boot partition is full. Quickest fix is to remove old kernels.

lightman47
Posts: 625
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Geforce 1050ti Driver issues.

Postby lightman47 » 2018/01/11 18:06:11

and for a more permanent fix, I edited /etc/yum.conf and changed the installonly_limit=3 instead of the default 5.

Note that this change does NOT immediately clean out old kernels; that auto 'cleanout' happens when a new kernel is installed during a future 'yum update'.
"Please solve your problems in advance so we can help you more"
- unknown

User avatar
TrevorH
Forum Moderator
Posts: 22591
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Geforce 1050ti Driver issues.

Postby TrevorH » 2018/01/11 18:31:39

Or when you run package-cleanup --oldkernels --count 3
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

supertight
Posts: 167
Joined: 2017/02/07 21:47:51

Re: Geforce 1050ti Driver issues.

Postby supertight » 2018/01/12 02:26:38

TrevorH wrote:Or when you run package-cleanup --oldkernels --count 3



I'm not sure this worked.

Code: Select all

Loaded plugins: fastestmirror, langpacks, nvidia
base/7/x86_64                                            | 3.6 kB     00:00
elrepo                                                   | 2.9 kB     00:00
extras/7/x86_64                                          | 3.4 kB     00:00
updates/7/x86_64                                         | 3.4 kB     00:00
No old kernels to remove


No old Kernels to remove?? Should I change my .ks file to make the /boot partition bigger?
Thanks for reading.

supertight
Posts: 167
Joined: 2017/02/07 21:47:51

Re: Geforce 1050ti Driver issues.

Postby supertight » 2018/01/12 02:43:09

supertight wrote:
TrevorH wrote:Or when you run package-cleanup --oldkernels --count 3



I'm not sure this worked.

Code: Select all

Loaded plugins: fastestmirror, langpacks, nvidia
base/7/x86_64                                            | 3.6 kB     00:00
elrepo                                                   | 2.9 kB     00:00
extras/7/x86_64                                          | 3.4 kB     00:00
updates/7/x86_64                                         | 3.4 kB     00:00
No old kernels to remove


No old Kernels to remove?? Should I change my .ks file to make the /boot partition bigger?
Thanks for reading.


I modified the Kickstart file to increase the /boot partition from 200mb to 800mb. Started a fresh install. Let's see how this bad dude works.

supertight
Posts: 167
Joined: 2017/02/07 21:47:51

Re: Geforce 1050ti Driver issues.

Postby supertight » 2018/01/12 03:03:42

supertight wrote:
supertight wrote:
TrevorH wrote:Or when you run package-cleanup --oldkernels --count 3



I'm not sure this worked.

Code: Select all

Loaded plugins: fastestmirror, langpacks, nvidia
base/7/x86_64                                            | 3.6 kB     00:00
elrepo                                                   | 2.9 kB     00:00
extras/7/x86_64                                          | 3.4 kB     00:00
updates/7/x86_64                                         | 3.4 kB     00:00
No old kernels to remove


No old Kernels to remove?? Should I change my .ks file to make the /boot partition bigger?
Thanks for reading.


I modified the Kickstart file to increase the /boot partition from 200mb to 800mb. Started a fresh install. Let's see how this bad dude works.



Still not working. Now I'm getting this set of warnings for the install.

Code: Select all

yum install $(nvidia-detect)
WARNING: Xorg log file /var/log/Xorg.0.log does not exist
WARNING: Unable to determine Xorg ABI compatibility
WARNING: The driver for this device does not support the current Xorg version


Thank you for reading.

User avatar
TrevorH
Forum Moderator
Posts: 22591
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Geforce 1050ti Driver issues.

Postby TrevorH » 2018/01/12 07:21:25

No old Kernels to remove??


Well, if you just did an install and followed that with a yum update then you'll only have 2 installed so package-cleanup --oldkernels --count 3 won't do anything as that command says to leave 3 kernels installed.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

supertight
Posts: 167
Joined: 2017/02/07 21:47:51

Re: Geforce 1050ti Driver issues.

Postby supertight » 2018/01/13 01:46:58

TrevorH wrote:
No old Kernels to remove??


Well, if you just did an install and followed that with a yum update then you'll only have 2 installed so package-cleanup --oldkernels --count 3 won't do anything as that command says to leave 3 kernels installed.


This info. While good to know. Doesn't help me much.

While trying to run, yum install $(nvidia-detect). I get the following errors.

Code: Select all

yum install $(nvidia-detect)
WARNING: Xorg log file /var/log/Xorg.0.log does not exist
WARNING: Unable to determine Xorg ABI compatibility
WARNING: The driver for this device does not support the current Xorg version


If anyone could point me in the correct direction for required reading, I would greatly appreciate it.
Thank you for reading.

supertight
Posts: 167
Joined: 2017/02/07 21:47:51

Re: Geforce 1050ti Driver issues.

Postby supertight » 2018/01/13 02:25:10

I managed to get the driver installed without error.
The following is the #1 google result when trying to google-fu this problem.
https://elrepo.org/bugs/view.php?id=426
I read this over several times. I took it to mean, this had been modified. Removing the need to start Xorg before installing the driver. So I never tried running xorg before the install. I ran startx and then did a reboot. The driver slipped right in. :lol:

A little confusing. But moving forward.
Thank you to everyone who posted. I'd be nowhere without this forum.