xrandr problem

Issues related to hardware problems
Post Reply
drfred
Posts: 10
Joined: 2018/01/12 03:24:42

xrandr problem

Post by drfred » 2018/01/25 01:47:14

I have moved this from an old topic

I have a Supermicro server running here at home to run my home entertainment system using Plex. I have a Buffalo Terastation NAS attached and have in total about 54T of space on my home network. I have about 40 devices running on my network behind a Juniper SRX220 router/firewall.

Now I have decided to intall Centos on half of the Supermicro. The other half runs Windows server. Why am I doing this? Why not? I like to have options and I thought it would be nice to have a Centos server running here...

Anyway, the Supermicro has a Matrox G200ew video card and the default settings of centos make me run in 1024x768, which I dislike. The Windows server on the other half runs the same Matrox card in 1280x1024 without any problems, so the hardware can do it.

I have blacklisted the mga g200 driver which forced the use of the vesa driver. This now shows all of the possible video modes including the 1280x1024

The problem is that Centos still does not recognize that my monitor can display these modes. I have a KVM switch which I took out, but the same problem persisted. Centos only displays 'Unknown display' with 1024x768.

Reading about this it appears that I can use xrandr to add the modes to x and make the change.

I then used gtf to get the video settings for 1280x1024 at various sync rates...60 Hz, 65 Hz, 75 Hz and have been trying to use xrandr to add these modes to the video card and screen.

I get all the way to trying to use the modes and then get:

Code: Select all

xrandr: Configure crtc 0 failed
Reading about this it seems the most common reason for this is that the hardware does not support the mode, but I know it does as Windows is able to run this resolution on this same machine!

Any ideas?

chemal
Posts: 411
Joined: 2013/12/08 19:44:49

Re: xrandr problem

Post by chemal » 2018/01/25 19:07:27

According to RH, you should be using the mgag200 kernel module together with Xorg's modesetting driver (now already included in the base xorg package):

https://access.redhat.com/documentation ... placements

The mgag200 driver is capable of programming video modes itself (like the Windows driver) and should be using your display's native resolution if your monitor supplies valid EDID.

If it doesn't, you can try with generic EDID by adding drm_kms_helper.edid_firmware=edid/1280x1024.bin to the kernel command line.

Or else create custom EDID, see /usr/share/doc/kernel-doc-3.10.0/Documentation/EDID/HOWTO.txt.

Post Reply