FCoE issue

Issues related to hardware problems
alex1010
Posts: 3
Joined: 2018/02/13 10:29:56

FCoE issue

Postby alex1010 » 2018/02/14 21:10:55

Hi,

I have asked already in Networking forum but seems nobody knows

I am trying to make work hp blade with netapp storage via FCoE gateway

FCoE subinterface is created and Fabric params are there but it stays Offline

[root@localhost ~]# rpm -qa | grep fcoe
fcoe-utils-1.0.32-1.el7.x86_64

[root@localhost ~]# fcoeadm -i
Description: OneConnect 10Gb NIC (be3)
Revision: 01
Manufacturer: Emulex Corporation
Serial Number:

Driver: be2net 11.4.0.0r
Number of Ports: 1

Symbolic Name: fcoe v0.1 over ens2f0.111-fcoe
OS Device Name: host8
Node Name: 0x1000009c023dbbf8
Port Name: 0x2000009c023dbbf8
Fabric Name: 0x10000027f8dd4e47
Speed: 10 Gbit
Supported Speed: 10 Gbit
MaxFrameSize: 1452 bytes
FC-ID (Port ID): 0x010001
State: Offline <<<


or


[root@localhost ~]# fcoeadm -i
Description: OneConnect 10Gb NIC (be3)
Revision: 01
Manufacturer: Emulex Corporation
Serial Number: 009C023DBBF8

Driver: be2net 11.4.0.0r
Number of Ports: 1

Symbolic Name: fcoe v0.1 over ens2f0.111-fcoe
OS Device Name: host8
Node Name: 0x1000009c023dbbf8
Port Name: 0x2000009c023dbbf8
Fabric Name: 0x0 <<<<
Speed: 10 Gbit
Supported Speed: 10 Gbit
MaxFrameSize: 1952 bytes
FC-ID (Port ID): 0x000000 <<<<<
State: Offline <<<<

in debug log I see
[ 6835.736983] libfcoe: host8: FIP selected Fibre-Channel Forwarder MAC 5c:45:27:c4:f0:20
[ 6835.736990] host8: xid 0: Exchange timer canceled
[ 6835.737019] host8: lport 000000: Received a FLOGI accept
[ 6835.737024] host8: Assigned Port ID 010001
[ 6835.737028] host8: lport 010001: Entered DNS state from FLOGI state
[ 6835.737033] host8: rport fffffc: Login to port
[ 6835.737036] host8: rport fffffc: Port entered PLOGI state from Init state
[ 6835.737053] host8: xid 2: Exchange timer armed : 20000 msecs
[ 6852.748769] host8: xid 4: Exchange timed out
[ 6855.756924] host8: xid 2: Exchange timed out
[ 6855.756933] host8: rport fffffc: Received a PLOGI response timeout
[ 6855.756938] host8: rport fffffc: Error -1 in state PLOGI, retrying
[ 6855.756945] host8: xid 2: f_ctl 90000 seq 1
[ 6855.756948] host8: xid 2: Exchange timer armed : 20000 msecs
[ 6855.756969] host8: rport fffffc: Port entered PLOGI state from PLOGI state
[ 6855.756984] host8: xid 12: Exchange timer armed : 20000 msecs

in packet capture on FCoE gateway don't see PLOGI
I suspect some issue with a driver on the server side

on each fcoe service restart bnx2fc loads
[ 394.563491] bnx2fc: QLogic FCoE Driver bnx2fc v2.10.3 (October 15, 2015)

maybe it interferes here?


Actually this is my first experience with FCoE , so need your help