Virtual Hard disk booting with SCSI stuck at prompt “probing EDD (edd=off to disable).. ok” where as Virtual Hard disk b

Issues related to hardware problems
Post Reply
rahulr440@gmail.com
Posts: 1
Joined: 2018/02/21 06:35:38

Virtual Hard disk booting with SCSI stuck at prompt “probing EDD (edd=off to disable).. ok” where as Virtual Hard disk b

Post by rahulr440@gmail.com » 2018/02/21 06:59:11

Q - Virtual Hard disk booting with SCSI stuck at prompt “probing EDD (edd=off to disable).. ok” where as Virtual Hard disk booting with IDE works fine

When I'm deploying a templates base centos 7 vm with SCSI interface vm stuck with EDD probing. Same way when I'm using IDE instead of SCSI its working fine. VM boots properly.
I want to use SCSI. I tried couple of things to update the grub file and kickstart file but no luck.

Installed open-vm-tools-10.1.5-3.el7.x86_64 on kernel 3.10.0-693.11.6.el7.x86_64.
cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)

tunk
Posts: 384
Joined: 2017/02/22 15:08:17

Re: Virtual Hard disk booting with SCSI stuck at prompt “probing EDD (edd=off to disable).. ok” where as Virtual Hard di

Post by tunk » 2018/02/22 13:02:38

I have no experience with open-vm-tools (and litte with VMs), but I would guess you have to convert the IDE "disk" to a SCSI "disk".

Devourer
Posts: 12
Joined: 2018/01/29 10:15:59

Re: Virtual Hard disk booting with SCSI stuck at prompt “probing EDD (edd=off to disable).. ok” where as Virtual Hard di

Post by Devourer » 2018/02/26 20:34:10

initramfs probably lacks of virtio/virtio-scsi modules, boot with IDE, try to regenerate initramfs with dracut adding virtio modules.

I'm not sure if they are not included by default, but It is worth a shot.

Post Reply