Hard lockup occurring when copying large files

Issues related to hardware problems
Post Reply
Posts: 3
Joined: 2018/03/06 06:10:08

Hard lockup occurring when copying large files

Post by danielrg » 2018/03/06 06:40:59

I am experiencing a hard lockup when copying files over 950MB in size from an external source on CentOS7 i386/i686. By hard lockup, I mean that my computer freezes (CAPS and SCROLL LOCK flash together) and I have to hold the power button 4 seconds, then turn it back on.

Could someone please help me figure out how to fix this issue? I think it's a challenging and esoteric one, niche for sure.

- I have an old Dell Latitude D630 laptop running an "Intel Core 2 Duo T7500 2.2 GHz", a 90GB hard drive, 4GB RAM, DVD Writer drive, wireless and wired network card.
- I wanted to run CentOS7 to run PLEX, but with an x86 CPU wasn't finding CentOS 7 anywhere, until I ran across this:
- "Live KDE" .iso found here: http://mirror.centos.org/altarch/7/isos/i386/
- plus yum install of latest plex media server
- I also made a couple changes so the wireless light wouldn't blink with data traffic
- I setup the plex media server, and disabled firewalld (systemctl disable firewalld)

So pretty simple how I got where I am. But I am using a less exercised version of CentOS7 for sure.

The next step was to get the large media files I wanted to serve with Plex installed. This is where things got weird.

1) I mounted a shared windows drive from the PC with the files, and tried to copy that way. When the first big file got to about 950 MB, the computer hard locked with the blinking caps and scroll lock lights. Second try, same thing.

2) I looked up the blinking lights issue. Happens to people with bad memory, but all of the posts I read about it they couldn't even boot. I was booting, Plex server running, everything seemed fine

3) I tried a USB stick also. Copied the files to USB stick, then plugged it in and copied from /run/media. Also locked up in the same way at 950 M.

4) I tried typing 'sync' a lot while the transfer was running

5) WORKAROUND: I removed one of the memory chips, so I only had 2GB RAM. The copy worked just fine. What?? Maybe I did have bad memory but just didn't access it until the big copy

6) Put all the memory back, after cleaning the terminals with some alcohol. Overnight ran comprehensive BIOS memory tests (they took about 3 hours). All the memory tests passed without any problems. So the memory seems like it's fine.

7) I thought - maybe 'cp' uses memory differently than, say, 'rsync'. So I tried rsync. Computer froze at the same spot in the large file.

8) I tried different large files, maybe that file had a problem. Tried three different files, they all hard froze computer.

So network and USB stick copies resulted in the same issue, and 'cp' and 'rsync' also both showed problem. So I don't know if this is a weird kernel bug, or if my memory really does have some super corner case issue the overnight memory tests didn't find, but I'm not a programmer, not an IT guru just an engineer that uses Linux at work for various aspects.

There's four things I can do:

1) Pull on the memory chip whenever I want to copy more big files to the computer
2) Wipe the computer and install CentOS6 which had a more supported i386/i686 content base and better tested
3) Try some expert ideas forwarded to me on this forum, and maybe fix it?
4) Blindly try a bunch of things and probably never figure really it out, then end up doing 1 or 2.

Anyone up for a challenge to help solve this problem?

Thanks in advance!

User avatar
Forum Moderator
Posts: 24809
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Hard lockup occurring when copying large files

Post by TrevorH » 2018/03/06 10:12:56

Everything you describe, especially the part about it working when you remove RAM, points to a hardware error. I'd recommend downloading and booting the memtest86+ iso image - leave it running overnight, preferably for 12+ hours.

Incidentally, not quite sure why you are using the altarch 32 bit build with a Core 2 Due T7500 as https://ark.intel.com/products/29761/In ... 00-MHz-FSB says it's a 64 bit capable processor so would run the 64 bit distro just fine.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Posts: 50
Joined: 2005/03/06 19:44:55

Re: Hard lockup occurring when copying large files

Post by glennzo » 2018/03/06 11:44:19

You remove a memory module, the copy works. You reinstall the memory module, the machine locks up. Replace the memory module.
Powered by Fedora and CentOS

Posts: 43
Joined: 2018/02/17 19:09:47

Re: Hard lockup occurring when copying large files

Post by john2018 » 2018/03/07 13:47:01

as above - but also check your bios settings and system voltages (for the ram.... especially)
Check Ras/Cas or whatever if its variable.

Posts: 3
Joined: 2018/03/06 06:10:08

Re: Hard lockup occurring when copying large files

Post by danielrg » 2018/03/10 07:27:17

Thank you everyone for the ideas on solving this problem. I did have another hardware error not related to copying that froze my server up after running for about 24 hours. Replacement memory like this is cheap - so I'll try that.

As for running the 32-bit distro, I must have checked a site that was mistaken about the processor and said it was 32-bit only. I'd prefer to run the 64-bit distro, much wider RPM selection and better used.

I'm going to re-install the 64-bit version and see how that performs against the memory chip. If I still have trouble, I'll replace it. It's like $20... so not a big deal. I will check the voltages too - as it could be the slot itself for some reason and not the memory.

The server runs fine with 2GB too, I noticed... but I haven't put any HD content on my Plex server yet. Again thanks everyone for the great advice. I'll report back.

Posts: 3
Joined: 2018/03/06 06:10:08

Re: Hard lockup occurring when copying large files

Post by danielrg » 2018/03/21 22:52:27

I found an old 1 GB memory stick and put it in. Everything's still working fine. So I have 3 GB RAM now anyhow.

Everything is working well, and PLEX doesn't need that much memory, so I'll probably leave things as they are - but at least I know it isn't the memory socket and likely the memory chip.

I didn't try memtest on the 2GB badly behaving chip, mostly because I didn't want to take the time - but it is funny that the CMOS built in tests didn't find any problems.

Either way, evidence seems to suggest that the memory chip was the issue. Thanks everyone for your help!

Post Reply