Unable to import Images from a Digital Camera - not solved

Issues related to hardware problems
Post Reply
khenrick
Posts: 10
Joined: 2016/09/25 12:37:25

Unable to import Images from a Digital Camera - not solved

Post by khenrick » 2018/06/17 13:30:15

I have had a similar issue as set out in redhat bug Bug 1551747
and in centos report [SOLVED] Unable to import Images from a Digital Camera

I had same problem with a canon G10 powershot with
libgphoto2-2.5.15-1.el7.x86_64 fixed with libgphoto2-2.5.17-1.ay.el7.x86_64.rpm

BUT BUT

The problem is with a Sony DSC-RX10M2

with libgphoto2-2.5.15-1.el7.x86_64 I get a mount point but when I mount I get the error
'deadbeef' from the library routine static int folder_list_func
at
/* invalid storage, storageinfo might fail on it (Nikon D300s e.g.) */
if ((params->storageids.Storage&0x0000ffff)==0) continue;
snprintf(fname, sizeof(fname), STORAGE_FOLDER_PREFIX"%08x", params->storageids.Storage);
CR (gp_list_append (list, fname, NULL)); }
} else {
char fname[PTP_MAXSTRLEN];
snprintf(fname, sizeof(fname), STORAGE_FOLDER_PREFIX"%08x", 0xdeadbeef);
gp_list_append (list, fname, NULL); }

trying libgphoto2-2.5.17-1.ay.el7.x86_64.rpm

I get no mount point and gvfs-ls /run/user/1000/gvfs is empty

with libgphoto2-2.5.15-1 it has the image dir - but hangs if one tries to access the directory

gvfs-ls /run/user/1000/gvfs/gphoto2:host=%5Busb%3A001%2C045%5D/store_deadbeef/2018-06-05/


previously the rather old libgphoto2-2.5.2-5.el7.x86_64 which was the precursor of
libgphoto2-2.5.15-1.el7.x86_64 either worked or the Sony camera was simply recognised as a usb file system
and now gphoto2 has taken over and cant handle it


the Sony camera has in its menu setup USB Connection MTP

lsusb
...
Bus 001 Device 048: ID 054c:09ec Sony Corp.
...

gphoto2 --auto-detect
Model Port
----------------------------------------------------------
USB PTP Class Camera usb:001,048


any of after setenv LANG C
gphoto2 --summary
gphoto2 --list-all-config
gphoto2 --capture-image

gives An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Device or resource busy). Make sure no other program (gvfs-gphoto2-volume-monitor) or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.

the nearest I can see to a supported camera is
Sony DSC-RX10M3 (Control) from http://www.gphoto.org/proj/libgphoto2/support.php
mine is Sony DSC-RX10M2

which used to work perfectly ??

is this a centos problem or a gphoto2 problem?


SonyRX10II.jpg
SonyRX10II.jpg (81.26 KiB) Viewed 260 times
thanks

kim

Post Reply