Page 1 of 1

Mouse and Keyboard not Working at Login Screen

Posted: 2018/07/11 04:38:37
by DarkAeon54
In trying to update my NVidia drivers somehow I screwed up my mouse and keyboard, I'm not sure how this even makes sense considering I only made changes to NVidia files/packages.

Background: I originally had elrepo packages managing my NVidia drivers, but when I tried to go and update the drivers, there was a conflict that I couldn't figure out how to fix, so I just tried to update the package using the NVidia website's provided download, in hopes that that would override the issues I was facing with elrepo.

Where I'm at: After installing the drivers, I restarted, arrived at the login screen, and mouse and keyboard don't work anymore. I initially thought the screen froze, but if I watch the clock at the top, I can see that the clock is still ticking and the time is still advancing, so the system isn't frozen. Which I can also assume that the NVidia drivers are working ok as well, since, well, there's a GUI. I then tried rebooting into mode and am able to type commands in that mode, so it's something that happens between and mode.

My question: What steps can I take to solve this issue? I'm not even sure where to start. How do people usually go about investigating and solving problems on Linux? (I'm still fairly new to linux)

Thank you

Re: Mouse and Keyboard not Working at Login Screen

Posted: 2018/07/11 09:02:35
by TrevorH
Read the logs under /var/log and look for errors. Use ls -lart /var/log to get a list in modification order, most recent at the end.

It would probably be better to fix the ELRepo problem than use the nvidia installer as that will break with every single kernel update that comes along where the ELRepo ones should only (usually) break on new point releases (i.e. you should be safe at least until 7.6 comes along).

Re: Mouse and Keyboard not Working at Login Screen

Posted: 2018/07/11 13:52:59
by DarkAeon54
Thank you that lead me in the right direction and I was able to solve my issue :)

What I did:
1. Uninstalled the nvidia 'run' file. Removed all packages with the word "nvidia" in them (just to get rid of everything that may cause a problem!!).
2. Realized I can use "--showduplicates" with yum to find the right version for kmod-nvidia and make yum install the correct package.
3. Searched where you said. (/var/log/), then check inside the file Xorg.0.log for errors.
4. There was an error in there that said "evdev" package was not found, so I ended up searching yum for anything with "evdev", found a generic looking package and installed it, restarted, and then my mouse and keyboard started working again.

Thank you so much for your help!

Re: Mouse and Keyboard not Working at Login Screen

Posted: 2018/07/11 13:56:12
by TrevorH
The most likely error that you might get from installing the latest ELRepo kmod-nvidia is a complaint at install time telling you about missing prereqs for the 7.5 series of kernels. If you have not yet updated to 7.5 using yum update (why not?!) then you cannot use the latest kmod-nvidia package which is built against it and requires it.

If you want further assistance solving the kmod-nvidia update problem then post all of the output from the yum command that gives the error.