Supermicro: CentOS 7 not recognizing RAID Volume

Issues related to hardware problems
Post Reply
MikeW83
Posts: 2
Joined: 2018/09/06 13:53:31

Supermicro: CentOS 7 not recognizing RAID Volume

Post by MikeW83 » 2018/09/06 14:03:39

Hello guys,

I'm new here an I have a question. I bought an Supermicro Server (A+ Server 1012A-MRF) with the following board: H8SML-iF

Now I'm searching for an option to get my RAID configuration working. With CentOS 6 I haven't any issues. But when I try to install CentOS 7 then the Volume is not showing up. I haven't seen that the compatibility in this chart https://www.supermicro.com/Aplus/suppor ... SR5650.cfm doesn't show up CentOS 7. Is there any possibility to install CentOS 7 with other drivers for the AMD SP5100 raid controller?
If yes, how do I implement these drivers before/during the installation process?

Thank you very much.


Best regards, Michael

User avatar
TrevorH
Forum Moderator
Posts: 23652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Supermicro: CentOS 7 not recognizing RAID Volume

Post by TrevorH » 2018/09/06 14:42:16

Google says an AMD SP5100 is a FakeRAID controller. In most cases I'd recommend disabling RAID mode and telling it to do AHCI then using linux software RAID as it's more reliable, better tested and mostly just works.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

MikeW83
Posts: 2
Joined: 2018/09/06 13:53:31

Re: Supermicro: CentOS 7 not recognizing RAID Volume

Post by MikeW83 » 2018/09/06 14:54:14

TrevorH wrote:
2018/09/06 14:42:16
Google says an AMD SP5100 is a FakeRAID controller. In most cases I'd recommend disabling RAID mode and telling it to do AHCI then using linux software RAID as it's more reliable, better tested and mostly just works.
Yes, that's true. It's not a real raid controller. I have the option to choose Adaptec and any other mode. Thank you for your recommendation. So I only have to switch back to AHCI and let CentOS handle the raid configuration?

Thank you!

Regards, Michael

User avatar
TrevorH
Forum Moderator
Posts: 23652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Supermicro: CentOS 7 not recognizing RAID Volume

Post by TrevorH » 2018/09/06 18:06:26

There should be options in the storage configuration panel inside the installer that let you set up software RAID. /boot has to be on a RAID 1 array due to BIOS considerations.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply