ACPI Sleep fails to resume from suspend2ram

Issues related to hardware problems
Post Reply
redbow.kimee
Posts: 1
Joined: 2018/09/30 18:18:50

ACPI Sleep fails to resume from suspend2ram

Post by redbow.kimee » 2018/09/30 20:57:32

Hi alls,

I've been having some sleep/resume issues on my laptop (HP Pavilion x360, late 2015) lately. I reinstalled (CentOS Linux release 7.5.1804 (Core)) a few days ago, because I wanted to re-balance space on my dual-boot.

Not necessarily important but here's some context
So first time I boot up after install (minimal install), I yum upgrade and run a few scripts to install the software I like.Next I reboot and shim fails to start seems to be related to this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1477735. So I went in again through the disk installer to "repair a system" and ran the following. Downgrading the kernel was only necessary due to version conflicts with downgrading shim.

Code: Select all

yum remove kernel-3.10.0-862.14.4.el7.x86_64
yum install kernel-3.10.0-862.11.6.el7.x86_64
yum downgrade shim-x64 mokutil
Here's my actual problem
Now When I suspend my device and attempt to resume, instead of resuming it will boot as if it had been powered completely off.

I've tried changing some of the kernel parameters per this thread on ask-ubuntu https://askubuntu.com/questions/24048/s ... ate-option. (note I also changed "update grub" to "grub2-mkconfig -o /boot/efi/EFI/centos/grub.cfg"

When that did not work, I tried changing a few related kernel options as per this documentation file https://www.kernel.org/doc/Documentatio ... meters.txt but I can't say I know what most of them mean.

this is what I have in my "/etc/default/grub" file:

Code: Select all

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="crashkernel=auto rd.lvm.lv=centos_red-october/root rhgb quiet"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_sleep=nonvs"
GRUB_DISABLE_RECOVERY="true"
some other diagnostics info

Code: Select all

kimee@red-october: ~
16:54:58> uname -a
Linux red-october.redbow.kim 3.10.0-862.11.6.el7.x86_64 #1 SMP Tue Aug 14 21:49:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
kimee@red-october: ~
16:55:03> cat /etc/centos-release
CentOS Linux release 7.5.1804 (Core) 
Lastly I've also attached some of my dmesg output "dmesg | grep -i -C5 acpi"

bonedome
Posts: 47
Joined: 2017/04/22 08:11:04

Re: ACPI Sleep fails to resume from suspend2ram

Post by bonedome » 2018/10/03 17:16:24

Hello
I suspect the problem will go away once you update to the 3.10.0-862.14.4 kernel
My laptop (dell e6420) would (most of the time) refuse to suspend when the lid was closed and my girlfriend's e6430 would do what you describe and shutdown.
This only started happening with the 3.10.0-862.11.6 kernel.
After searching the web I tried editing /etc/systemd/logind.conf to uncomment the lines
HandleSuspendKey=suspend
HandleLidSwitch=suspend
which seemed to do the trick, although it took about 30 secs to a minute to suspend.
Since the new kernel it suspends almost instantly.

Post Reply