I/O Errors on reboot, can't enter root mode

Issues related to hardware problems
Post Reply
Bashed
Posts: 23
Joined: 2015/10/17 23:22:57

I/O Errors on reboot, can't enter root mode

Post by Bashed » 2018/10/01 02:57:28

This is what I see... Shows boot screen fine, Centos 7 option then the error.

https://ibb.co/ehdTGz

I have KVM crash cart hooked up. Can’t boot into ssh or root.

Bashed
Posts: 23
Joined: 2015/10/17 23:22:57

Re: I/O Errors on reboot, can't enter root mode

Post by Bashed » 2018/10/01 03:12:48

Booted into Centos 7 live CD (troubleshooting mode) via KVM/IP virtual console. Ran xfs_repair. Doesn't seem like anything was fixed however, it just displayed these 7 phases in a flash.

https://ibb.co/fwWOYe

Bashed
Posts: 23
Joined: 2015/10/17 23:22:57

Re: I/O Errors on reboot, can't enter root mode

Post by Bashed » 2018/10/01 03:15:44

Rebooted again, now I see this error. If I open the server, how do I know which slots are B1 and B4?

https://ibb.co/jL78zK

tunk
Posts: 437
Joined: 2017/02/22 15:08:17

Re: I/O Errors on reboot, can't enter root mode

Post by tunk » 2018/10/01 12:26:24

You could try to run smartctl -a /dev/sda|more to see if there's a hardware problem.
I think the slots should be marked on the motherboard.
You could try to reseat the modules a few times - it may (or not) fix the problem.

User avatar
TrevorH
Forum Moderator
Posts: 23861
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: I/O Errors on reboot, can't enter root mode

Post by TrevorH » 2018/10/01 17:08:29

That looks like you have RAM problems and your data has been corrupted and then written to disk. I suspect you will need to break out your backups and restore the data since you cannot rely on it any more.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply