Upgraded to 7.6 - laptop keyboard no longer works

Issues related to hardware problems
User avatar
mdecheser
Posts: 6
Joined: 2019/03/01 14:34:12
Location: Philadelphia, PA

Re: Upgraded to 7.6 - laptop keyboard no longer works

Post by mdecheser » 2019/04/02 18:57:48

Hi TrevorH and everyone else.

I resorted to rebuilding my system. Everything is working fine now (of course). I wish I could know WTF I did to my system to wreck it like that. At least I know the hardware (and 7.6) is fine :)

Cheers,
MD

desertcat
Posts: 631
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: Upgraded to 7.6 - laptop keyboard no longer works

Post by desertcat » 2019/04/09 09:23:37

mdecheser wrote:
2019/04/02 18:57:48
Hi TrevorH and everyone else.

I resorted to rebuilding my system. Everything is working fine now (of course). I wish I could know WTF I did to my system to wreck it like that. At least I know the hardware (and 7.6) is fine :)

Cheers,
MD
OK now that you have rebuilt the system, now would be an EXCELLENT time to BACKUP the ENTIRE drive. If God forbid something were to take the system down ... or did something stupid (GUILTY as charged) ... you can RESTORE the system back to a known and working state.

JayBeeDe
Posts: 1
Joined: 2019/10/03 09:12:43

Re: Upgraded to 7.6 - laptop keyboard no longer works

Post by JayBeeDe » 2019/10/03 09:20:08

Hi,

Just to let you know that I had exactly the same issue but on CentOS 7.7 : no laptop keyboard on X session, USB keyboard ok on X session, both keyboards ok on tty, both keyboards ok on grub menu.
I fixed the keyboard issue by removing the xorg-x11-drv-libinput-0.27.1-2.el7.x86_64 package. I had manually installed this package in the past to reverse the vertical scroll of the mouse, and I notice the laptop keyboard issue only a few days later (I use an external keyboard most of the time). So now I'm back with my vertical scrolling issue, but it is not as dramatic as the keyboard laptop issue...

Post Reply

Return to “CentOS 7 - Hardware Support”