nvidia driver only working on a my external monitor hdmi not my internal laptop

Issues related to hardware problems
Post Reply
xbatx
Posts: 76
Joined: 2010/08/28 08:49:31

nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by xbatx » 2019/11/12 20:09:44

nvidia driver only working on a my external hdmi monitor not my internal laptop. The internal screen stops at Started Dynamic System Tuning Daemon. I ran a update today yum install $(nvidia-detect).. Once I did that now it only works on the external not internal monitor connected to my laptop.

Code: Select all

lspci | grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

Code: Select all

nvidia-detect
kmod-nvidia
An Intel display controller was also detected

Code: Select all

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00*+  59.94    50.00    60.05    60.00    50.04  
   1680x1050     59.95  
   1600x1200     60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94  

Code: Select all

 sudo yum list installed | grep -i nvidia
Loaded plugins: fastestmirror, langpacks, nvidia
kmod-nvidia.x86_64                     440.31-1.el7_7.elrepo          @elrepo   
nvidia-detect.x86_64                   430.40-1.el7.elrepo            @elrepo   
nvidia-x11-drv.x86_64                  440.31-1.el7_7.elrepo          @elrepo   
nvidia-x11-drv-libs.x86_64             440.31-1.el7_7.elrepo          @elrepo   
yum-plugin-nvidia.noarch               1.0.2-1.el7.elrepo             @elrepo  

chemal
Posts: 613
Joined: 2013/12/08 19:44:49

Re: nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by chemal » 2019/11/12 20:39:21

You have an Optimus system. The internal display is connected to the Intel GPU and the external display to the Nvidia GPU. Elrepo's package comes with an xorg.conf like this:

Code: Select all

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
EndSection
This gives you an X server that only runs on the Nvidia card and therefore only drives your external display.

If you want X on the internal display you have to make sure the X server also drives the Intel GPU. And if the Nvidia card is to render something on the internal display, it has to copy its images to the Intel GPU's frame buffer for actual display. This is the tricky part.

As far as I know linux+optimus is still a mess. You should read https://download.nvidia.com/XFree86/Lin ... index.html for the current state of affairs.

xbatx
Posts: 76
Joined: 2010/08/28 08:49:31

Re: nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by xbatx » 2019/11/12 20:41:45

Thank you. I will read that. You have any suggestions on how to get my laptop monitor back to working correctly.
Also this is my current -

Code: Select all

  GNU nano 2.3.1                                                                                          File: /etc/X11/xorg.conf                                                                                                                                                                                           

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.31

# /etc/X11/nvidia-xorg.conf provided by http://elrepo.org

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen	0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "intel"
    ModelName	   "Intel Corporation"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName	   "GeForce GTX 1050 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "BaseMosaic" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


chemal
Posts: 613
Joined: 2013/12/08 19:44:49

Re: nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by chemal » 2019/11/12 20:49:28

(Re)moving /etc/X11/xorg.conf should give you back X on the internal display. For optimus the autogenerated xorg.conf is as useless as the elrepo one.

xbatx
Posts: 76
Joined: 2010/08/28 08:49:31

Re: nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by xbatx » 2019/11/12 20:52:42

thank you. I will try that.

Update - fantastic!! that worked! Thank You! Now its back to my regular old internal screen. I will try to do some reading to figure out whats going with that mess. I miss the dual monitors :(
Last edited by xbatx on 2019/11/12 20:58:15, edited 2 times in total.

chemal
Posts: 613
Joined: 2013/12/08 19:44:49

Re: nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by chemal » 2019/11/12 20:56:42

You can also try this as a start: https://wiki.gentoo.org/wiki/NVIDIA/Optimus/xorg.conf (You need to substitute the right BusID.)

xbatx
Posts: 76
Joined: 2010/08/28 08:49:31

Re: nvidia driver only working on a my external monitor hdmi not my internal laptop

Post by xbatx » 2019/11/12 21:03:47

Thank you again. Now its just a matter of converting the 01:00.0 to hex if I understand it correctly.

Post Reply

Return to “CentOS 7 - Hardware Support”