[SOLVED] Kickstart CentOS 7 Network issue

Issues related to configuring your network
Post Reply
erbr
Posts: 6
Joined: 2017/12/06 14:18:29

[SOLVED] Kickstart CentOS 7 Network issue

Post by erbr » 2017/12/06 14:31:03

Hi,

We are installating CentOS 7 on a HP elitedesk with kickstart and it works fine except for the networking section.
In the kickstart-file we say:
network --onboot=on --bootproto=static --device=eno1 --gateway=x.x.x.x --ip=x.x.x.x --netmask=x.x.x.x. -nameserver:x.x.x.x,x.x.x.x -hostname=hostname1.domain.local --activate --noipv6

After last reboot the computer prompt us to complete the "yellow section", which is the network settings.
We dont have to change anything just click on the network, and then click done and then Finish Configuration. The system is booting and it works fine.
We dont want the system to prompt us for this. Do you have any idea why this happen?
Last edited by erbr on 2017/12/11 10:55:57, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 23678
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Kickstart CentOS 7 Network issue

Post by TrevorH » 2017/12/06 20:00:03

I'd start by trying --onboot yes
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

erbr
Posts: 6
Joined: 2017/12/06 14:18:29

Re: Kickstart CentOS 7 Network issue

Post by erbr » 2017/12/07 14:13:40

Thanks for your answer TrevorH
We have already tried with --onboot yes and --onboot=on but it doesnt work.
We hav also uninstalled the virtual network adapters named virbr.. something but it doesnt make any difference either.

Any other ideas?

tunk
Posts: 424
Joined: 2017/02/22 15:08:17

Re: Kickstart CentOS 7 Network issue

Post by tunk » 2017/12/07 14:38:41

I've never used kickstart, but are these typos:
- colon in nameserver
- single hyphen in nameserver and hostname

Therion7777
Posts: 2
Joined: 2016/03/17 09:44:11

Re: Kickstart CentOS 7 Network issue

Post by Therion7777 » 2017/12/08 12:54:05

Strange.

I have no "onboot" options at my kickstart files and NIS is up always after installation :)

User avatar
jlehtone
Posts: 2006
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Kickstart CentOS 7 Network issue

Post by jlehtone » 2017/12/11 08:53:39

erbr wrote:We dont have to change anything just click on the network, and then click done and then Finish Configuration. The system is booting and it works fine.
Compare

Code: Select all

/root/anaconda-ks.cfg
to your kickstart file. Any differences?

erbr
Posts: 6
Joined: 2017/12/06 14:18:29

Re: Kickstart CentOS 7 Network issue

Post by erbr » 2017/12/11 10:44:50

Thanks for all replies!

We solved it by removing the package chrony.x86_64.
We added the following row in our kickstart file:
yum -y remove chrony.x86_64

The installation is now fully completed without user interaction.

User avatar
jlehtone
Posts: 2006
Joined: 2007/12/11 08:17:33
Location: Finland

Re: [SOLVED] Kickstart CentOS 7 Network issue

Post by jlehtone » 2017/12/11 13:50:40

Interesting,
1. Yes, chrony depends on network, but should not affect it.
2. In %post ? Best way to prevent installation of a package is to not include it or to blacklist it in %packages.

erbr
Posts: 6
Joined: 2017/12/06 14:18:29

Re: [SOLVED] Kickstart CentOS 7 Network issue

Post by erbr » 2017/12/11 14:43:09

Yes, we have it the %post-section for the moment and we may move it up to the %packages instead. We have som tuning to do in this file related to package installations/uninstallations.

Before we excluded the chrony package from the kickstart file we had problem with the SSSD and NTPD-service.
The services doesnt start after first boot but now they do. I dont know why but Im glad its working now.
Im new to CentOS, I have been working with microsoft Products the last 17 years and now I trying to learn this :)

Post Reply