Server killing my internet

Issues related to configuring your network
Post Reply
FurnaceRocker
Posts: 3
Joined: 2018/09/09 01:16:48

Server killing my internet

Post by FurnaceRocker » 2018/09/20 13:33:04

Hey,

I set up a server using CentOS 7, and I'm running plex on it to organize movies and music. A problem I'm running into is that when my server is plugged into the router, it slows my internet down considerably. I don't ever lose network connection from my router, but as I'm browsing I often get the "can't connect to website" error. I do also see a significant difference in the speed of my internet between when I have my server on and not on.

So far, I've tried changing the router, and I've tried changing the IP address, but neither of those have really worked. I'm aware that I might not have a fast enough network (it's currently 50Mbps), and if upgrading it to 100 is the solution I'm open to trying that. However, my gut tells me that the server shouldn't really affect my connection to the internet, because it isn't actually going through the internet at all, it's only connected in my home network.

Anyone have any ideas that could help? Thanks!

User avatar
TrevorH
Forum Moderator
Posts: 23644
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Server killing my internet

Post by TrevorH » 2018/09/20 14:10:44

Use tcpdump or wireshark to dump the traffic and see what's there. It could be that you have something installed on the server that shouldn't be there and is sending traffic to somewhere you don't want it to go.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Romario Picari
Posts: 2
Joined: 2018/09/10 09:10:49

Re: Server killing my internet

Post by Romario Picari » 2018/09/21 06:19:10

I had the same problem , and this was cause to dos attacks. My server kept uploading at 100mbps all the time.
You can check it with "iftop" or "iptraf" also.
I suggest blocking all ports except ones u need.

User avatar
TrevorH
Forum Moderator
Posts: 23644
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Server killing my internet

Post by TrevorH » 2018/09/21 07:25:22

Or maybe tracking down whatever it is that installed and finding out if it can be removed. If whatever it is is running as root then reinstall as it's not recoverable.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
avij
Forum Moderator
Posts: 2676
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Server killing my internet

Post by avij » 2018/09/21 07:37:50

Some "media servers" may have "plugins" allowing you to download movies from the Internet (probably illegally) using a peer-to-peer protocol, and that may cause your network to become congested. Perhaps check that option first.

FurnaceRocker
Posts: 3
Joined: 2018/09/09 01:16:48

Re: Server killing my internet

Post by FurnaceRocker » 2018/09/27 04:04:01

Well, got it to work by reinstalling the OS. Yeah there must have been a program somewhere that was messing with it. On running iftop I ran into a long story that made me need to reinstall the OS. Thanks for the help!

Post Reply