Page 1 of 1

Netgear A6100 wifi adapter

Posted: 2016/04/23 21:05:44
by mcarson1111
I have a Netgear WiFi adapter, model A6100, and it does not work with my CentOS 7 install. I ran yum update and my kernel was updated. I found this but it did not work. I have the driver files unzipped but I when I use the "make" command it says I missing a library files. The error message is "No file or directory found" and it is looking under /lib/modules/{my kernel name}/build.

Any help is much appreciated!

[Moderator: split this post away from an unrelated thread]

Re: Netgear A6100 wifi adapter

Posted: 2016/04/23 21:47:22
by TrevorH
Please post the output from the lsusb command while the adapter is plugged in.

Re: Netgear A6100 wifi adapter

Posted: 2016/04/25 22:25:22
by mcarson1111
TrevorH wrote:Please post the output from the lsusb command while the adapter is plugged in.
It is:

Bus 002 Device 002: ID 0845:9052 Netgear, Inc. A600 AC600 DB Wireless Adapter RealteK RTL8811AU

Re: Netgear A6100 wifi adapter

Posted: 2017/12/24 14:44:47
by Baars
Have the same issue
us 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Re: Netgear A6100 wifi adapter

Posted: 2018/01/18 01:18:32
by Lyght
Has anyone found a resolution to this issue, i just loaded my first attempt at CentOS on a Dell Poweredge 1750 server, and unfortunately my wife says to loud to stay in an upstairs the to basement it shall go! so it needs Wifi instead of hard wire.

When i run lsusb it does list the Netgear, i did check ElRepo for the device ID (Not found)

The chipset is the RT8811 AU

I do have the device drivers for windows as .exe, i did try to use ndiswrapper and of course that failed.

I loaded wireless tools
ran iwconfig, and it shows no wifi devices.

Any assistance would be awesome as i would like to get this server moved tonight so i can actually start using it.

Re: Netgear A6100 wifi adapter

Posted: 2018/01/20 03:18:59
by Lyght
So exhausting hours, I've attempted two different installs. I tried the RTL8811au driver from this link here. ... b-adapter/

Everything worked like a charm, even up to the modprobe 8812au, checked lsmod, showed it running.

still iwconfig showed now wifi devices. ip link showed no device :(

So the second attempt i tried was uninstalling everything above, starting from scratch.


Attempted running the make/make install


So at this point i'm at 2 conclusions. I'm trying to hunt down a CentOS 7 USB wifi device that's plug and play or reload with RHEL, which i really don't want to do but i cannot run the servers in the network room, the wife says no, so means i cant work on them they are paper weights until i get some type of WIFI enablement.

Re: Netgear A6100 wifi adapter

Posted: 2018/01/20 10:35:57
by TrevorH
If it doesn't work with CentOS then it's 99.99% likely that it won't work with RHEL either since CentOS is a rebuild of RHEL sources.

Your best bet is to raise an RFE ticket on the ELRepo bug tracker and ask them if they can produce a kmod package for that adapter.

Also, as an aside, a 1750 is so old and power hungry that it's very likely that it would be way out performed by a cheap low power device and the savings in electricity would probably pay for it in months.

Re: Netgear A6100 wifi adapter

Posted: 2018/01/21 04:45:15
by Lyght
Thanks TrevorH for the response.

Well if that adapter is going to be a pain in the rear, is there a listed document on Centos Kernel supported drivers?
I know it's all based on chipset, so it's hard to determine what chip is what when you buy. I went and bought a Belkin, and is a damn RTL8892 chip.... Gahhhh!!! annoying.

I actually have 2 Dell 1750 poweredge servers :) I got them for 50 bucks fully loaded 10k speed hard drives, Raid 1 with two backups, fully loaded 8GB memory sticks packed. Dual quad core Xeon 2.3Ghz.

I'm really aiming to do some hadoop clustering and hopefully shared processing on the two, for personal playground. I have some python machine learning i'm really looking to play with.

Have any suggestions on a usable usb wifi device that's not so difficult to install?
as far as electric bill goes, i mean for the price i got these two machines i thought it was a steal.

Re: Netgear A6100 wifi adapter

Posted: 2018/01/21 10:51:50
by TrevorH
Having googled around a bit, I'm quite surprised that you even got CentOS 7 to load on those. The info I found says that a 1750 is from 2003 and had 32 bit xeon processors. Are you using CentOS 7 x86_64 or the altarch 32 bit build? If you've loaded the altarch 32 bit version then that would mean that you'd be unable to use any of the kmod drivers from ELRepo which is 64 bit only for CentOS 7 so you'll be limited to whatever is shipped by the distro itself.

The distro kernel ships the ath9k module which supports a long list of Atheros chipsets. Run `modinfo ath9k` and you'll see a lot of lines like

alias: pci:v0000168Cd00000036sv00001028sd0000020Ebc*sc*i*

and those tell you which vendor/device ids it supports. I'm a bit confused by that list as they all seem to be PCI not USB but...

You can also look under /lib/modules/3.10.0-693.11.6.el7.x86_64/kernel/drivers/net/wireless for other modules that are shipped by the distro and run modinfo on each of those.