No Ethernet Access in Centos 7?

Issues related to configuring your network
swilliams
Posts: 2
Joined: 2017/08/22 17:42:23

No Ethernet Access in Centos 7?

Postby swilliams » 2017/08/22 18:22:42

Hello,

I just installed Centos 7 on a machine to be what I'm hoping will be a home server, but I have no internet access. I don't have an option to add ethernet either and am uncertain what the problem is or where to begin to fix it.
ifconfig -a is only giving me options for lo, virbr0, and virbr0-nic and the same for ip link command.

I'm fine with editing in vim or nano, but at this point I'm not sure what I would need to edit, I'm still a rather novice when it comes to Centos.

Thanks for you help in advanced.

swilliams

Additional Info:
Kernel Version: 3.10.0-514.el7.x86_64 x86_64
Adapter: 00:07.0 Bridge [0680]: NVIDIA Corporation MCP61 Ethernet [10de:03ef] (rev a2)

If you need more info please ask, but I hope this is helpful to helping me find a solution. So far, I've only been able to find the issue for virtual machine installations, which doesn't help me at all.

swilliams
Posts: 2
Joined: 2017/08/22 17:42:23

Re: No Ethernet Access in Centos 7?

Postby swilliams » 2017/08/22 22:49:18

UPDATE: Finally located a workaround after much Googling. The dreaded NVIDIA problems resolved with kmod-forcedeth from ELRepo.

Sadly, when I "yum update" I get this:

Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-12.el7.centos.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-12.el7.centos.x86_64
ipa-client-common-4.4.0-12.el7.centos.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-12.el7.centos.noarch
ipa-common-4.4.0-12.el7.centos.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-12.el7.centos.noarch

Any ideas on how to fix? I went ahead and tried the "--skip-broken," but if there is indeed an update for these I'd truly would prefer to have them installed.

User avatar
jlehtone
Posts: 1823
Joined: 2007/12/11 08:17:33
Location: Finland

Re: No Ethernet Access in Centos 7?

Postby jlehtone » 2017/08/23 05:49:13

The ipa-package dependecy misconfiguration is a known issue.

You probably don't have IPA IdM in use and therefore uninstalling the ipa-* is an option.

User avatar
TrevorH
Forum Moderator
Posts: 20569
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: No Ethernet Access in Centos 7?

Postby TrevorH » 2017/08/23 09:28:37

Just ignore those errors, they are harmless and will be fixed in 7.4.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke