PXE boot CentOS LiveDVD results in timeout

Issues related to configuring your network
beta-tester
Posts: 10
Joined: 2017/11/05 13:53:25

Re: PXE boot CentOS LiveDVD results in timeout

Post by beta-tester » 2018/05/14 10:12:24

TrevorH wrote:
[here the init.repo option]
Did you mean "inst.repo="?
sorry... yes, "inst.repo=...", that what i mean...
i have corrected in my previous post...
it was a typo + copy'n'past mistake of me.
...thanks for pointing this.

to be very sure, i took a look to my pxelinux.cfg/default file i used.
"inst.repo=..." is not working for me.

hunter86_bg
Posts: 1372
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: PXE boot CentOS LiveDVD results in timeout

Post by hunter86_bg » 2018/05/15 04:02:01

Is it working for regular DVD? Take the install dvd and try with that- it might be specific issue with the live dvd or something distro specific.

beta-tester
Posts: 10
Joined: 2017/11/05 13:53:25

Re: PXE boot CentOS LiveDVD results in timeout

Post by beta-tester » 2018/08/07 07:55:36

the problem seems to be that kiwi module (dracut-kiwi-live) does not implement root=live:<url>... (used by openSUSE and CentOS, Fedora uses default dracut with livenet module)
see error: don't know how to handle 'root=live:<url>'
and Bug 1099548 - can't PXE-boot into openSUSE Leap 15.0 Live image

pingchi
Posts: 1
Joined: 2018/08/12 05:53:06

Re: PXE boot CentOS LiveDVD results in timeout

Post by pingchi » 2018/08/12 06:41:17

beta-tester wrote:
2018/05/13 20:08:01
thank you, but the option inst.repo=... didn't work.
i tried

Code: Select all

LABEL CentOS x64
    KERNEL /nfs/centos-x64/isolinux/vmlinuz0
    APPEND initrd=/nfs/centos-x64/isolinux/initrd0.img [here the inst.repo option] ro rd.lvm=0 rd.luks=0 rd.md=0 rd.dm=0 vga=794 -- vconsole.font=latarcyrheb-sun16 vconsole.keymap=de-latin1-nodeadkeys locale.LANG=de_DE.UTF-8
    TEXT HELP
        Boot to CentOS LiveGNOME
        User: liveuser
    ENDTEXT
with those combinations as inst.repo options...

Code: Select all

inst.repo=nfs:[ip-of-nfs-server]:/srv/iso/centos-x64.iso
inst.repo=nfs:[ip-of-nfs-server]:/srv/nfs/centos-x64/
inst.repo=nfs:[ip-of-nfs-server]:/srv/nfs/centos-x64/LiveOS/
inst.repo=nfs:[ip-of-nfs-server]:/srv/nfs/centos-x64/LiveOS/squashfs.img
inst.repo=nfs:[ip-of-nfs-server]:/srv/nfs/centos-x64-squashfs-root-content/LiveOS/
inst.repo=nfs:[ip-of-nfs-server]:/srv/nfs/centos-x64-squashfs-root-content/LiveOS/ext2fs.img
i run into the emergency console because root could not be found...
Screenshot from 2018-05-13 22-14-49.png
Screenshot from 2018-05-13 22-14-09.png
Screenshot from 2018-05-13 22-19-48.png

the link you gave i have to study and try out... thanks.
Hey,
Did you fix this problem?
I also met the similar message: Failed to start Switch Root, if I use netboot file from Live.iso

Finally, I used netboot of non-live installation.iso to fix this problem.
Take CentOS 7.5 (1804) for example:
My PXE provide the CentOS 7.5-Live boot option as below.

The netboot file: {vmlinuz, initrd.img}, was copy from CentOS-7-x86_64-DVD-1804.iso
And live-OS Source was copy from CentOS-7-x86_64-LiveGNOME-1804.iso
And the pxelinux.cfg/default provide the option as below.

Code: Select all

label 1
kernel CentOS7up5-live_64/vmlinuz
append initrd=CentOS7up5-live_64/initrd.img inst.repo=nfs:192.168.0.10:/OS/CentOS7up5-live_64/
    

Post Reply