[solved] Unable to connect to centos server in the local network

Issues related to configuring your network
Post Reply
Chrysostomus
Posts: 3
Joined: 2017/12/03 21:43:18

[solved] Unable to connect to centos server in the local network

Post by Chrysostomus » 2017/12/03 21:54:16

Greetings!

I set up a nextcloud server using apache, mariadb, php7.1 and nextcloud 12. Everything seems to work otherwise, except that I cannot connect to the server in the local network.

The server is visible in the network:

Code: Select all

arp-scan --interface=wlp2s0 --localnet
...
192.168.1.81    18:67:b0:10:6e:5a       Samsung Electronics Co.,LTD
...
But I cannot ping it:

Code: Select all

ping 198.168.1.81
PING 198.168.1.81 (198.168.1.81) 56(84) bytes of data.
^C
--- 198.168.1.81 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4040ms
I have opened ports 22, 80 and 443 and also tried to connect with the firewall disabled. I also tried setting selinux to permissive, but it made no difference.

Centos can connect to internet and happily ping the computers in the local network.

Can anyone give me a hint on how to troubleshoot this? Any help is much appreciated!
Last edited by Chrysostomus on 2017/12/04 13:21:20, edited 2 times in total.

User avatar
TrevorH
Forum Moderator
Posts: 22999
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Unable to connect to centos server in the local network

Post by TrevorH » 2017/12/03 22:20:52

I have opened ports 22, 80 and 443 and also tried to connect with the firewall disabled
How? What exactly did you do?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Chrysostomus
Posts: 3
Joined: 2017/12/03 21:43:18

Re: Unable to connect to centos server in the local network

Post by Chrysostomus » 2017/12/04 06:54:41

firewall-cmd --zone=public --permanent --add-service=https
firewall-cmd --zone=public --permanent --add-service=http
firewall-cmd --zone=public --permanent --add-service=ssh
firewall-cmd --zone=public --permanent --add-port=22/tcp
firewall-cmd --zone=public --permanent --add-port=80/tcp
firewall-cmd --zone=public --permanent --add-port=443/tcp
firewall-cmd --reload

Chrysostomus
Posts: 3
Joined: 2017/12/03 21:43:18

Re: Unable to connect to centos server in the local network

Post by Chrysostomus » 2017/12/04 13:20:31

I moved the server to another network, and issue just dissappeared. It was therefore probably about the router and not about centos.

Post Reply