Page 1 of 1

[SOLVED] Kickstart CentOS 7 Network issue

Posted: 2017/12/06 14:31:03
by erbr
Hi,

We are installating CentOS 7 on a HP elitedesk with kickstart and it works fine except for the networking section.
In the kickstart-file we say:
network --onboot=on --bootproto=static --device=eno1 --gateway=x.x.x.x --ip=x.x.x.x --netmask=x.x.x.x. -nameserver:x.x.x.x,x.x.x.x -hostname=hostname1.domain.local --activate --noipv6

After last reboot the computer prompt us to complete the "yellow section", which is the network settings.
We dont have to change anything just click on the network, and then click done and then Finish Configuration. The system is booting and it works fine.
We dont want the system to prompt us for this. Do you have any idea why this happen?

Re: Kickstart CentOS 7 Network issue

Posted: 2017/12/06 20:00:03
by TrevorH
I'd start by trying --onboot yes

Re: Kickstart CentOS 7 Network issue

Posted: 2017/12/07 14:13:40
by erbr
Thanks for your answer TrevorH
We have already tried with --onboot yes and --onboot=on but it doesnt work.
We hav also uninstalled the virtual network adapters named virbr.. something but it doesnt make any difference either.

Any other ideas?

Re: Kickstart CentOS 7 Network issue

Posted: 2017/12/07 14:38:41
by tunk
I've never used kickstart, but are these typos:
- colon in nameserver
- single hyphen in nameserver and hostname

Re: Kickstart CentOS 7 Network issue

Posted: 2017/12/08 12:54:05
by Therion7777
Strange.

I have no "onboot" options at my kickstart files and NIS is up always after installation :)

Re: Kickstart CentOS 7 Network issue

Posted: 2017/12/11 08:53:39
by jlehtone
erbr wrote:We dont have to change anything just click on the network, and then click done and then Finish Configuration. The system is booting and it works fine.

Compare

Code: Select all

/root/anaconda-ks.cfg

to your kickstart file. Any differences?

Re: Kickstart CentOS 7 Network issue

Posted: 2017/12/11 10:44:50
by erbr
Thanks for all replies!

We solved it by removing the package chrony.x86_64.
We added the following row in our kickstart file:
yum -y remove chrony.x86_64

The installation is now fully completed without user interaction.

Re: [SOLVED] Kickstart CentOS 7 Network issue

Posted: 2017/12/11 13:50:40
by jlehtone
Interesting,
1. Yes, chrony depends on network, but should not affect it.
2. In %post ? Best way to prevent installation of a package is to not include it or to blacklist it in %packages.

Re: [SOLVED] Kickstart CentOS 7 Network issue

Posted: 2017/12/11 14:43:09
by erbr
Yes, we have it the %post-section for the moment and we may move it up to the %packages instead. We have som tuning to do in this file related to package installations/uninstallations.

Before we excluded the chrony package from the kickstart file we had problem with the SSSD and NTPD-service.
The services doesnt start after first boot but now they do. I dont know why but Im glad its working now.
Im new to CentOS, I have been working with microsoft Products the last 17 years and now I trying to learn this :)