Getting wireless to work - Dell Vostro 1500

Issues related to configuring your network
sudz28
Posts: 2
Joined: 2016/11/13 16:15:09

Getting wireless to work - Dell Vostro 1500

Postby sudz28 » 2017/12/17 21:24:11

My son left behind his old Dell Vostro 1500 laptop when he went off to school a couple of years ago, so I recently dusted it off and installed Centos7 on it. I've never deal with wireless adapters/drivers on Linux before, and while I can see that it recognizes that it has one with "lspci |grep -i broadcom" (returns "Network controller: Broadcom Limited BCM4311 802.11b/g WLAN (rev 01)), if I run "ifconfig" I don't see it. When I actually try to switch the wireless feature on on the laptop, it won't even light up.

I found a bit of a 'walkthrough' that seems to point me in the right direction in general, https://wiki.centos.org/HowTos/Laptops/ ... s/Broadcom, but I've never done make files before and what I'm getting doesn't seem to match what I should be getting according to their instructions (when I run make -C /lib/modules/`uname -r`/build/ M=`pwd`). When I run the command, I get "make: entering directory blahblahblah, Building modules, stage 2, and MODPOST 0 modules, followed by make: Leaving directory. There is no .ko file left behind.

Any help or advice would be appreciated!

bonedome
Posts: 24
Joined: 2017/04/22 08:11:04

Re: Getting wireless to work - Dell Vostro 1500

Postby bonedome » 2017/12/17 22:19:35

Hello
give this guide a try https://elrepo.org/tiki/wl-kmod that's what I do.
There should be a kernel module called brcmsmac already installed, you can give it a try with.
as root

Code: Select all

modprobe brcmsmac

That also works on my Dell but is much much slower than the hybrid.