public network problem in CentOS Linux release 7.4.1708

Issues related to configuring your network
Post Reply
kiraji
Posts: 3
Joined: 2018/01/09 04:28:46

public network problem in CentOS Linux release 7.4.1708

Post by kiraji » 2018/01/09 05:01:50

Guys,

I am a Linux Administrator and am facing a strange network problem in CentOS 7.4.1708. Public network will not respond until we manually turn off and turn on enp7s0f0 interface. It happens atleast two times in a day. I am able to access server via private network and issue is only with public interface. Also I would like to say you that am facing same problem in most of servers that have CentOS 7.4.1708.

===============
- First server
# uname -r
3.10.0-693.5.2.el7.x86_64
# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)
# cat /etc/sysconfig/network-scripts/ifcfg-enp7s0f0
HWADDR=x.x.x.x
TYPE=Ethernet
BOOTPROTO=none
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=enp7s0f0
UUID=x.x.x.x
ONBOOT=yes
IPADDR=x.x.x.x
GATEWAY=x.x.x.x
PREFIX=xx
DNS1=x.x.x.x
DNS2=x.x.x.x

- Second server
# uname -r
3.10.0-693.11.1.el7.x86_64
# cat /etc/redhat-release
CentOS Linux release 7.4.1708 (Core)
# cat /etc/sysconfig/network-scripts/ifcfg-enp8s0f0
TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_FAILURE_FATAL="no"
IPV6_ADDR_GEN_MODE="stable-privacy"
NAME="enp8s0f0"
UUID=x.x.x.x
DEVICE="enp8s0f0"
ONBOOT="yes"
IPADDR=x.x.x.x
PREFIX=xx
GATEWAY=x.x.x.x
DNS1=x.x.x.x
DNS2=x.x.x.x
IPV6ADDR=x.x.x.x.x.x.x.x
IPV6_DEFAULTGW=x.x.x.x
IPV6_PEERDNS="yes"
IPV6_PEERROUTES="yes"
IPV6_PRIVACY="no"
===============

We have checked all logs and there is nothing to trace this issue. Some blogs it is advised to disable network manager and I have done it. Still it is happening. However we are using CentOS for more than one year and there is no problem with CentOS 7 server upto 7.3 version. I don't think that it is hardward issue as 7.3.1611 version is running fine on same server specification. Problem is happening only for latest version. I don't know whether anyone is facing similar issue. So please help me to sort it out.

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 23672
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: public network problem in CentOS Linux release 7.4.1708

Post by TrevorH » 2018/01/09 12:52:20

You have GATEWAY= in both ifcfg files and it can only be in one of them.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kiraji
Posts: 3
Joined: 2018/01/09 04:28:46

Re: public network problem in CentOS Linux release 7.4.1708

Post by kiraji » 2018/01/09 13:32:53

Hello TrevorH,

Thanks for reply. I think you have confused with output. Those are output of two different servers. I have mentioned it as first and second server. I just want to show you all that I am facing same issue in multiple servers which is of same release 7.4.1708.

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 23672
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: public network problem in CentOS Linux release 7.4.1708

Post by TrevorH » 2018/01/09 13:35:02

Check in /var/log/messages for errors.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kiraji
Posts: 3
Joined: 2018/01/09 04:28:46

Re: public network problem in CentOS Linux release 7.4.1708

Post by kiraji » 2018/01/09 16:04:50

Hi TrevorH,

There is no errors on /var/log/messages.

Thanks
Kiraji

Post Reply