Connection to own DNS server

Issues related to configuring your network
vicwoods
Posts: 11
Joined: 2018/01/22 14:30:04

Connection to own DNS server

Postby vicwoods » 2018/01/24 17:16:14

I've build a DNS server and a client using virtualbox

Server has ip's 10.0.2.15 (NAT) and 172.20.0.2 (Intern)
Client has ip 172.20.0.101 (intern)

I'm trying to connect my client to my DNS server. I've changed the nameserver to 172.20.0.2 I thought that was it but it doenst seem to work. What Am i forgetting?

User avatar
TrevorH
Forum Moderator
Posts: 21712
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Connection to own DNS server

Postby TrevorH » 2018/01/24 17:47:42

Check that it listens on other than localhost? Check that the firewall ports are open?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

vicwoods
Posts: 11
Joined: 2018/01/22 14:30:04

Re: Connection to own DNS server

Postby vicwoods » 2018/01/24 18:22:21

When I do netstat -tulnp I get the following result

https://imgur.com/SsXSSZE

So i recon it isn't listening? How can I add it? And I suppose I should add the 172.20.0.2?

I should have a tcp 0 172.20.0.2 in there right? How can i do that?

User avatar
TrevorH
Forum Moderator
Posts: 21712
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Connection to own DNS server

Postby TrevorH » 2018/01/24 22:10:25

That's not just not listening, that looks like not running. I'd check /var/log/messages for errors as well as systemctl status and journalctl output.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

vicwoods
Posts: 11
Joined: 2018/01/22 14:30:04

Re: Connection to own DNS server

Postby vicwoods » 2018/01/25 08:49:43

DNSmasq is running on the server and journalctl doesn't give me an error (I think)

https://imgur.com/n6t05JH this is the output I get

A dnsmasq --test tells me the syntax is ok. So I assume it's some setting on the workstation I forgot. Anny ideas?

vicwoods
Posts: 11
Joined: 2018/01/22 14:30:04

Re: Connection to own DNS server

Postby vicwoods » 2018/01/25 14:11:39

Found the problem, firewall settings on the server..