Bonding on CENTOS7 issue with DF=1

Issues related to configuring your network
Post Reply
Simon168
Posts: 2
Joined: 2018/06/01 08:08:26

Bonding on CENTOS7 issue with DF=1

Post by Simon168 » 2018/06/01 08:15:24

Dear All,

Now i met one issue relate with bonding interface on Physical Server running CENTOS-7.
We I try to do file transfer from Physical to Physical and then capture packet, i found DF=1 (Don't Fragment Set= 1) in every packets.
It looks like it tell its peer don't sent big frame.

If anybody meet issue the same me, please share your advice.

Best Regards,
Chhayheng

User avatar
TrevorH
Forum Moderator
Posts: 23042
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Bonding on CENTOS7 issue with DF=1

Post by TrevorH » 2018/06/01 14:02:02

I tried a quick test from a machine using bonding and without breaking out the packet capture, it doesn't look like that from here.

Code: Select all

# ping -4 -c 1 -s 1473 vmhost
PING vmhost.trevor.local (192.168.1.6) 1473(1501) bytes of data.
1481 bytes from vmhost.trevor.local (192.168.1.6): icmp_seq=1 ttl=64 time=0.285 ms
# ping -4 -c 1 -M do -s 1473 vmhost
PING vmhost.trevor.local (192.168.1.6) 1473(1501) bytes of data.
ping: local error: Message too long, mtu=1500
# ping -4 -c 1 -M do -s 1472 vmhost
PING vmhost.trevor.local (192.168.1.6) 1472(1500) bytes of data.
1480 bytes from vmhost.trevor.local (192.168.1.6): icmp_seq=1 ttl=64 time=0.259 ms
So that first ping is a test without forcing DF and it works. The 2nd and 3rd pings force DF to be set and the first of those uses the same packet size as the first ping (without DF specified) and fails, thus showing that the first one worked and did not have DF set). The 3rd ping then reduces the packet size to fit without fragmentation being required and also works.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Simon168
Posts: 2
Joined: 2018/06/01 08:08:26

Re: Bonding on CENTOS7 issue with DF=1

Post by Simon168 » 2018/06/04 10:21:26

So do you have any solution for that ?

User avatar
TrevorH
Forum Moderator
Posts: 23042
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Bonding on CENTOS7 issue with DF=1

Post by TrevorH » 2018/06/04 10:54:18

I think I demonstrated that I don't appear to have the same problem.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply