How can I make sure that port 8787 works

Issues related to configuring your network
Post Reply
pierrot10
Posts: 3
Joined: 2017/11/28 12:27:46

How can I make sure that port 8787 works

Post by pierrot10 » 2018/10/09 09:57:10

Good day,

I ma managing a cluster with centos 7.
All work fine. The firewall is disable and we can display a web page (port 80) about the cluster status.
On the master I installed Rstudio server and the procedure asked me to enable the firewall and open the port 8787. Later I had to open the port 80 as well.
The problem is since I enabled the firewall, the nodes do not communicate with the master.

From this point, I have a couple of question:
I would like to disable the firewall as before. But how can make sure that Rstudion server work with the port 8787?
And why the nodes can communicate with the Master, while the port 8787 can not, when the firewall is disabled?

If I absolutely need to enable the firewall, is there a command to let me know which port I have to open for the node?

I would prefer to leave my cluster as it is (the firewall disabled) but port 8787 would not work...

Many thank for your advises.
Cheers
Pierre

tunk
Posts: 444
Joined: 2017/02/22 15:08:17

Re: How can I make sure that port 8787 works

Post by tunk » 2018/10/09 11:33:24

I have no experience with Rstudio and I'm not sure if I understand your setup.
I think I would start with looking at the documentation. As for opening ports in
the firewall, it depends on if you're using firewalld (default) or iptables.
You can use nmap to see if ports are open, e.g.:
nmap -p 8787,80 dns.name.or.ip.address

User avatar
TrevorH
Forum Moderator
Posts: 23876
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: How can I make sure that port 8787 works

Post by TrevorH » 2018/10/10 14:32:59

No firewall means ALL ports are open including 8787.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply