Failed to start The Apache ...

Issues related to configuring your network
Post Reply
boang
Posts: 4
Joined: 2019/02/14 09:08:03

Failed to start The Apache ...

Post by boang » 2019/02/14 09:20:16

Please help me with this.. website is currently down due to this error

Code: Select all

[root@localhost ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-02-14 17:03:56 PST; 2min 6s ago
     Docs: man:httpd.service(8)
  Process: 4328 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 4328 (code=exited, status=1/FAILURE)
   Status: "Reading configuration..."

Feb 14 17:03:51 localhost.localdomain systemd[1]: Starting The Apache HTTP Se...
Feb 14 17:03:56 localhost.localdomain systemd[1]: httpd.service: main process...
Feb 14 17:03:56 localhost.localdomain systemd[1]: Failed to start The Apache ...
Feb 14 17:03:56 localhost.localdomain systemd[1]: Unit httpd.service entered ...
Feb 14 17:03:56 localhost.localdomain systemd[1]: httpd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
[root@localhost ~]# service httpd status -l
Redirecting to /bin/systemctl status  -l httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-02-14 17:03:56 PST; 2min 15s ago
     Docs: man:httpd.service(8)
  Process: 4328 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 4328 (code=exited, status=1/FAILURE)
   Status: "Reading configuration..."

Feb 14 17:03:51 localhost.localdomain systemd[1]: Starting The Apache HTTP Server...
Feb 14 17:03:56 localhost.localdomain systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Feb 14 17:03:56 localhost.localdomain systemd[1]: Failed to start The Apache HTTP Server.
Feb 14 17:03:56 localhost.localdomain systemd[1]: Unit httpd.service entered failed state.
Feb 14 17:03:56 localhost.localdomain systemd[1]: httpd.service failed.
and when using webmin this will be the error

Code: Select all

Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
running the command "systemctl status httpd.service" in terminal

Code: Select all

● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2019-02-14 17:12:38 PST; 6min ago
     Docs: man:httpd.service(8)
  Process: 16459 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 16459 (code=exited, status=1/FAILURE)
   Status: "Reading configuration..."

Feb 14 17:12:38 localhost.localdomain systemd[1]: Starting The Apache HTTP Server...
Feb 14 17:12:38 localhost.localdomain systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Feb 14 17:12:38 localhost.localdomain systemd[1]: Failed to start The Apache HTTP Server.
Feb 14 17:12:38 localhost.localdomain systemd[1]: Unit httpd.service entered failed state.
Feb 14 17:12:38 localhost.localdomain systemd[1]: httpd.service failed.
journalctl -xe, which give me this one:

Code: Select all

 Feb 14 17:12:38 localhost.localdomain systemd[1]: Cannot add dependency job for 
Feb 14 17:12:38 localhost.localdomain systemd[1]: Starting The Apache HTTP Serve
-- Subject: Unit httpd.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit httpd.service has begun starting up.
Feb 14 17:12:38 localhost.localdomain systemd[1]: httpd.service: main process ex
Feb 14 17:12:38 localhost.localdomain systemd[1]: Failed to start The Apache HTT
-- Subject: Unit httpd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit httpd.service has failed.
-- 
-- The result is failed.
Feb 14 17:12:38 localhost.localdomain systemd[1]: Unit httpd.service entered fai
Feb 14 17:12:38 localhost.localdomain systemd[1]: httpd.service failed.
Feb 14 17:12:42 localhost.localdomain nautilus-deskto[15202]: g_simple_action_se
Feb 14 17:14:05 localhost.localdomain nautilus-deskto[15202]: g_simple_action_se
Feb 14 17:14:38 localhost.localdomain dbus[3700]: [system] Activating service na
Feb 14 17:14:38 localhost.localdomain dbus[3700]: [system] Successfully activate
Feb 14 17:15:07 localhost.localdomain nautilus-deskto[15202]: g_simple_action_se
Can someone help me please. I'm not really good at this I just read manual.
CentOS Linux release 7.6.1810 (Core)

User avatar
TrevorH
Forum Moderator
Posts: 26324
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Failed to start The Apache ...

Post by TrevorH » 2019/02/14 10:19:50

Check your logs under /var/log/httpd, especially the *error* ones.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

boang
Posts: 4
Joined: 2019/02/14 09:08:03

Re: Failed to start The Apache ...

Post by boang » 2019/02/15 01:28:40

Sir, Thank you very much for replying with my problem.

Code: Select all

[Thu Feb 14 17:12:38.665415 2019] [suexec:notice] [pid 16459:tid 140246332901568] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Feb 14 17:12:38.702544 2019] [lbmethod_heartbeat:notice] [pid 16459:tid 140246332901568] AH02282: No slotmem from mod_heartmonitor
[Thu Feb 14 17:12:38.703233 2019] [http2:warn] [pid 16459:tid 140246332901568] AH02951: mod_ssl does not seem to be enabled
[Thu Feb 14 17:12:38.738456 2019] [proxy_hcheck:crit] [pid 16459:tid 140246332901568] AH03262: mod_watchdog is required
[Thu Feb 14 17:12:38.738483 2019] [:emerg] [pid 16459:tid 140246332901568] AH00020: Configuration Failed, exiting
[Fri Feb 15 09:17:52.296671 2019] [suexec:notice] [pid 9139:tid 140372402075840] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Feb 15 09:17:52.331966 2019] [lbmethod_heartbeat:notice] [pid 9139:tid 140372402075840] AH02282: No slotmem from mod_heartmonitor
[Fri Feb 15 09:17:52.332636 2019] [http2:warn] [pid 9139:tid 140372402075840] AH02951: mod_ssl does not seem to be enabled
[Fri Feb 15 09:17:52.437874 2019] [proxy_hcheck:crit] [pid 9139:tid 140372402075840] AH03262: mod_watchdog is required
[Fri Feb 15 09:17:52.437897 2019] [:emerg] [pid 9139:tid 140372402075840] AH00020: Configuration Failed, exiting
I tried to search over the internet but somewhat confuse with the answers are not related to centos 7.

boang
Posts: 4
Joined: 2019/02/14 09:08:03

Re: Failed to start The Apache ...

Post by boang » 2019/02/15 02:48:18

i got it working.. phew :idea:

due to apache recent udpate i have to add mod_watchdog on my 00-base.conf

and Apache is working good. Thanks

boang
Posts: 4
Joined: 2019/02/14 09:08:03

Re: Failed to start The Apache ...

Post by boang » 2019/02/15 03:12:55

Now the Big problem is - localhost can no longer be access in my browser and it will automatically goes to https://localhost

it gives me

Code: Select all

Unable to connect

Firefox can’t establish a connection to the server at localhost.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.
but i can access apache successfully on 127.0.0.1

Uhmm is it safe now to Run my website?

User avatar
TrevorH
Forum Moderator
Posts: 26324
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Failed to start The Apache ...

Post by TrevorH » 2019/02/15 03:38:46

Your log is complaining about mod_ssl not being enabled which would be why you cannot connect to https.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply