Lots of errors in Samba log

Issues related to configuring your network
Post Reply
Elliott
Posts: 25
Joined: 2018/09/14 01:30:14

Lots of errors in Samba log

Post by Elliott » 2019/09/11 23:21:39

I installed Samba 4.8.3 on CentOS 7.6 and I am seeing lots of errors in the log when the service starts. I can't figure out what is actually the problem. I am able to mount the home directory remotely and everything seems fine so far, but I would like to clean up the log file so that real errors are easier to find.

Code: Select all

[2019/09/11 16:15:51.489156,  1] ../source3/profile/profile.c:51(set_profile_level)
  INFO: Profiling turned OFF from pid 948
[2019/09/11 16:15:51.504426,  0] ../lib/util/become_daemon.c:138(daemon_ready)
  daemon_ready: STATUS=daemon 'smbd' finished starting up and ready to serve connections
[2019/09/11 16:15:51.509030,  1] ../source3/printing/printer_list.c:234(printer_list_get_last_refresh)
  Failed to fetch record!
[2019/09/11 16:15:51.516549,  1] ../source3/lib/messages.c:879(send_all_fn)
  send_all_fn: messaging_send_buf to 827 failed: NT_STATUS_OBJECT_NAME_NOT_FOUND
[2019/09/11 16:15:51.516676,  1] ../source3/lib/messages.c:879(send_all_fn)
  send_all_fn: messaging_send_buf to 828 failed: NT_STATUS_OBJECT_NAME_NOT_FOUND
[2019/09/11 16:15:51.516737,  1] ../source3/lib/messages.c:879(send_all_fn)
  send_all_fn: messaging_send_buf to 928 failed: NT_STATUS_OBJECT_NAME_NOT_FOUND
[2019/09/11 16:15:51.516799,  1] ../source3/lib/messages.c:879(send_all_fn)
  send_all_fn: messaging_send_buf to 929 failed: NT_STATUS_OBJECT_NAME_NOT_FOUND
  
My smb.conf:

Code: Select all

[global]
	security = user
	passdb backend = tdbsam
	logging = file
	log level = 1
[homes]
	comment = Home Directories
	valid users = %S, %D%w%S
	browseable = No
	read only = No
	inherit acls = Yes

tunk
Posts: 585
Joined: 2017/02/22 15:08:17

Re: Lots of errors in Samba log

Post by tunk » 2019/09/12 10:41:26

The CR repo has samba-4.9.1-6 which may/may not solve your problem
(see second post here)(NB: this will update your system to CentOS 7.7):
viewtopic.php?f=47&t=71607

Post Reply

Return to “CentOS 7 - Networking Support”