Network not loaded correctly

Issues related to configuring your network
Post Reply
sionsavior
Posts: 1
Joined: 2019/09/16 23:49:06

Network not loaded correctly

Post by sionsavior » 2019/09/17 00:06:38

Hello,
I'm new to the world of CentOS.
I have a question I don't understand.
I have set up a fresh Centos 7.6 server. This works very well.
I tried to configure the network. However, this also works.
My problem is that after rebooting the system this configuration is not loaded.

Code: Select all

 nmcli con show
NAME           UUID                                  TYPE      DEVICE
enp3s0         63bfc60e-b6b8-4a26-838d-559db85a6e51  ethernet  enp3s0
enp3s0-static  88b89321-50cc-4153-991c-aa93748b59ce  ethernet  --
Only "enp3s0" is always loaded. Even if I delete this interface, this interface is automatically created and loaded again after a restart.

Code: Select all

[root@nova ~]# nmcli con up "enp3s0-static"
Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3)
[root@nova ~]# nmcli con show
NAME           UUID                                  TYPE      DEVICE
enp3s0-static  88b89321-50cc-4153-991c-aa93748b59ce  ethernet  enp3s0
When I execute this command, the interface "enp3s0" is deleted and the static is loaded at least as long as I don't restart.

After a fresh restart:

Code: Select all

[root@nova ~]# nmcli con show
NAME           UUID                                  TYPE      DEVICE
enp3s0         63bfc60e-b6b8-4a26-838d-559db85a6e51  ethernet  enp3s0
enp3s0-static  88b89321-50cc-4153-991c-aa93748b59ce  ethernet  --
my network folder looks like this

Code: Select all

[root@nova network-scripts]# ls -l
total 216
-rw-r--r-- 1 root root   617 Sep 17 01:40 ifcfg-enp3s0
-rw-r--r-- 1 root root   254 Aug 24  2018 ifcfg-lo
lrwxrwxrwx 1 root root    24 Dec  5  2018 ifdown -> ../../../usr/sbin/ifdown
-rwxr-xr-x 1 root root   654 Aug 24  2018 ifdown-bnep
-rwxr-xr-x 1 root root  6532 Aug 24  2018 ifdown-eth
.
.
.
-rwxr-xr-x 1 root root  1836 Aug 24  2018 ifup-wireless
-rwxr-xr-x 1 root root  5419 Aug 24  2018 init.ipv6-global
-rw-r--r-- 1 root root 20671 Aug 24  2018 network-functions
-rw-r--r-- 1 root root 31027 Aug 24  2018 network-functions-ipv6
The file has the following contents

Code: Select all

HWADDR=50:xxx6:xxD:5xx3:7xx:7xx
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=static
IPADDR=78.xx.xx.x2
PREFIX=24
GATEWAY=78.xxx.xxx.x3
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV4_DNS_PRIORITY=100
IPV6INIT=yes
IPV6_AUTOCONF=no
IPV6ADDR=2a01:xxx:xxx:6xxxcxx::2/64
IPV6_DEFAULTGW=fe80::1
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
IPV6_DNS_PRIORITY=100
NAME=enp3s0-static
UUID=88b89321-50cc-4153-991c-aa93748b59ce
DEVICE=enp3s0
ONBOOT=yes
DHCP=no
DNS1=213.x.x.98
DNS2=213.x.x.99
DNS3=213.x.x.100
DNS4=2a01:xxx:xxx:1::add:1xxx
DNS5=2a01:xxx:xxx:1::add:2xxx
DNS6=2a01:xxx:xxx:1::add:3xxx

hunter86_bg
Posts: 1906
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: Network not loaded correctly

Post by hunter86_bg » 2019/09/17 03:11:53

Can you provide some log data .
For example output in /var/log/messages or in the 'journalctl -u NetworkManager.service' ?
This will explain the behaviour and what should be done .

Post Reply

Return to “CentOS 7 - Networking Support”