disabled firewalld now ssh broken

Support for security such as Firewalls and securing linux
Post Reply
jott440
Posts: 3
Joined: 2014/08/24 03:07:39

disabled firewalld now ssh broken

Post by jott440 » 2014/08/24 03:19:28

I was setting up CentOS 7 in a lab environment and disabled firewalld
systemctl stop firewalld.service
systemctl disable firewalld.service
Now I can't ssh in any longer. My guess is my ssh_config file won't work using the defaults now that the firewall is off. Is this correct?

But I have read that firewalld can go into panic mode when crossed... is there fail-safe ssh_config I can use to test? have been reading up but still a newb with ssh_config. thx in advance...

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: disabled firewalld now ssh broken

Post by gerald_clark » 2014/08/24 15:59:58

Disabling firewalld will not prevent ssh logins.
The cause lies elsewhere.

The ssh daemon uses sshd_config not ssh_config.

jott440
Posts: 3
Joined: 2014/08/24 03:07:39

Re: disabled firewalld now ssh broken

Post by jott440 » 2014/08/26 21:12:47

Thanks for the reply. You are 100% correct... disabling firewalld does NOT appear to impact sshd.

But does it impact other aspects of networking?

Disabling firewalld DID appear to disable my eth0 interface and prevent it from coming up on boot. Is this expected? Sort of a failsafe after dropping the firewall? The goal here is to go back to iptables...

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: disabled firewalld now ssh broken

Post by gerald_clark » 2014/08/26 21:24:56

Disabling firewalld does not prevent the network from starting up.

Please read the FAQ http://wiki.centos.org/FAQ/CentOS7
It covers the problems you may be experiencing.

Unless you have a specific reason for running MetworkManager, disable it and run the network service instead.
Make sure the interface has onboot=yes.

Post Reply

Return to “CentOS 7 - Security Support”