[SOLVED] Iperf not responding as server

Support for security such as Firewalls and securing linux
Post Reply
informel
Posts: 5
Joined: 2018/05/29 00:15:32

[SOLVED] Iperf not responding as server

Post by informel » 2018/05/29 01:31:49

I have a fresh new install of CentOs (as a VM on my ESXI 6.7 server) and I am using it as a Plex server and it is running fine.

I want to test the network speed with iperf3.

Iperf is install, if I use it as a client; I can setup a Windows machine as a server and it is working.
If I start iperf on CentOs as a server, it is telling me that it is listening on port 5201., but the clients are timing out.

port is open in the Firewall
[plex@localhost ~]$ firewall-cmd --list-ports
5201/tcp

suggestion??
Last edited by informel on 2018/05/30 14:11:12, edited 1 time in total.

mghe
Posts: 696
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Iperf not responding as server

Post by mghe » 2018/05/29 08:05:19

Check Your iperf server up and running.

informel
Posts: 5
Joined: 2018/05/29 00:15:32

Re: Iperf not responding as server

Post by informel » 2018/05/29 17:08:12

5201/tcp
[plex@localhost ~]$ iperf3 -s
-----------------------------------------------------------
Server listening on 5201
---------------------------------

mghe
Posts: 696
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Iperf not responding as server

Post by mghe » 2018/05/29 17:41:53

Did You reload firewalld ?

# firewall-cmd --reload

Use 'nmap' and scan Your server and check open ports

mghe
Posts: 696
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Iperf not responding as server

Post by mghe » 2018/05/29 18:04:44

informel wrote:5201/tcp
[plex@localhost ~]$ iperf3 -s
-----------------------------------------------------------
Server listening on 5201
---------------------------------
Try to run server ipv4 only

# iperf3 -s -4

informel
Posts: 5
Joined: 2018/05/29 00:15:32

Re: Iperf not responding as server

Post by informel » 2018/05/29 19:27:05

mghe wrote:Did You reload firewalld ?

# firewall-cmd --reload

Use 'nmap' and scan Your server and check open ports
Yes I did a reload
and the port is open:
[plex@localhost ~]$ firewall-cmd --list-ports
5201/tcp

informel
Posts: 5
Joined: 2018/05/29 00:15:32

Re: Iperf not responding as server

Post by informel » 2018/05/29 19:55:03

informel wrote:
mghe wrote:Did You reload firewalld ?

# firewall-cmd --reload

Use 'nmap' and scan Your server and check open ports
Yes I did a reload
and the port is open:
[plex@localhost ~]$ firewall-cmd --list-ports
5201/tcp
but nmap does not show this port:
Scanning localhost (127.0.0.1) [65535 ports]
Discovered open port 25/tcp on 127.0.0.1
Discovered open port 111/tcp on 127.0.0.1
Discovered open port 22/tcp on 127.0.0.1
Discovered open port 32600/tcp on 127.0.0.1
Discovered open port 32401/tcp on 127.0.0.1
Discovered open port 1116/tcp on 127.0.0.1
Discovered open port 631/tcp on 127.0.0.1
Discovered open port 51413/tcp on 127.0.0.1
Discovered open port 5201/tcp on 127.0.0.1
Discovered open port 39122/tcp on 127.0.0.1
Discovered open port 46250/tcp on 127.0.0.1
Discovered open port 32400/tcp on 127.0.0.1
Discovered open port 32469/tcp on 127.0.0.1

mghe
Posts: 696
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Iperf not responding as server

Post by mghe » 2018/05/29 19:59:54

Nmap use from client to scan server,

Did You try run server only Ipv4 ?

# iperf3 -s -4

informel
Posts: 5
Joined: 2018/05/29 00:15:32

Re: Iperf not responding as server

Post by informel » 2018/05/30 01:10:41

mghe wrote:Nmap use from client to scan server,

Did You try run server only Ipv4 ?

# iperf3 -s -4

OK you are the best
it does work with -4

note: I am new to this forum, Do I have to do anything to close the thread or to give you credit ?

tunk
Posts: 351
Joined: 2017/02/22 15:08:17

Re: Iperf not responding as server

Post by tunk » 2018/05/30 12:01:41

You could edit the title of the thread:
[SOLVED] Iperf not responding as server

Post Reply