Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Support for security such as Firewalls and securing linux
Post Reply
mySKILLZ
Posts: 17
Joined: 2018/02/21 09:10:21

Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by mySKILLZ » 2018/07/06 09:23:43

im getting this error while installing certbot for security

---> Package e2fsprogs.x86_64 0:1.42.9-10.el7 will be updated
---> Package e2fsprogs.x86_64 0:1.42.9-12.el7_5 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.42.9-10.el7 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.9-12.el7_5 will be an update
---> Package libselinux-python.x86_64 0:2.5-11.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-12.el7 will be an update
---> Package libselinux-utils.x86_64 0:2.5-11.el7 will be updated
---> Package libselinux-utils.x86_64 0:2.5-12.el7 will be an update
---> Package libsepol.x86_64 0:2.5-6.el7 will be updated
---> Package libsepol.x86_64 0:2.5-8.1.el7 will be an update
---> Package libss.x86_64 0:1.42.9-10.el7 will be updated
---> Package libss.x86_64 0:1.42.9-12.el7_5 will be an update
---> Package python-pip.noarch 0:7.1.0-1.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: python-pip-7.1.0-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: python-pip-7.1.0-1.el6.noarch (epel)
Requires: python(abi) = 2.6
Installed: python-2.7.5-68.el7.x86_64 (@base)
python(abi) = 2.7
python(abi) = 2.7
Available: python34-3.4.8-1.el6.i686 (epel)
python(abi) = 3.4
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Could not install OS dependencies. Aborting bootstrap!

tell me why?

User avatar
avij
Forum Moderator
Posts: 2718
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by avij » 2018/07/06 10:02:05

Mixing el6 and el7 packages will not work. Which version of CentOS are you running? What does rpm -q centos-release output?

User avatar
avij
Forum Moderator
Posts: 2718
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by avij » 2018/07/06 10:06:15

In either case, the first steps to resolve this problem are:
yum clean all
yum remove epel-release
yum install epel-release --enablerepo=extras

After this is done, you may need to do some manual work to uninstall and reinstall the EPEL packages that do not match your operating system version. For that, rpm -qa | grep el6 may help if you are running CentOS 7. This command will list the (EP)EL6 packages you have installed.

mySKILLZ
Posts: 17
Joined: 2018/02/21 09:10:21

Re: Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by mySKILLZ » 2018/07/06 10:36:04

i got this after typing the version commade check

centos-release-7-4.1708.el7.centos.x86_64

mySKILLZ
Posts: 17
Joined: 2018/02/21 09:10:21

Re: Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by mySKILLZ » 2018/07/06 10:37:37

ok here is another thing

[root@skill ~]# rpm -qa | grep el6
remi-release-6.9-2.el6.remi.noarch
[root@skill ~]#

User avatar
avij
Forum Moderator
Posts: 2718
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by avij » 2018/07/06 10:39:47

OK, that looks like CentOS 7 then. See my above message for further instructions. After you have cleaned up your system of EL6 packages you should yum update to upgrade to 7.5.1804.

As for remi-release, you will need to yum remove remi-release, and then install the el7 equivalent if you need packages from that repository. Remi's pages have instructions for installing the correct remi-release.

mySKILLZ
Posts: 17
Joined: 2018/02/21 09:10:21

Re: Error: Package: python-pip-7.1.0-1.el6.noarch (epel)

Post by mySKILLZ » 2018/07/06 10:47:04

ok installing certbot worked..

dont go away ima get back to u again if anything pop off again

Post Reply