Fresh instal won't boot

Issues related to applications and software problems and general support
Post Reply
Martin8
Posts: 2
Joined: 2019/09/24 11:57:30

Fresh instal won't boot

Post by Martin8 » 2019/09/24 12:06:08

Hi,

I've installed a fresh install CentOS 8 on HyperV, default settings, Gen1/Gen2 (Same issue).
But I can't get it to boot after the setup wizzard finishes, and prompts for a reboot.
It just gets stuck at the blinking prompt, and never actually boots up.

Any Suggestions?

Thanks,
Attachments
Screen Shot
Screen Shot
Centos.PNG (45.69 KiB) Viewed 3670 times

alfredmyers
Posts: 1
Joined: 2019/09/24 20:28:06
Location: São Paulo, BR
Contact:

Re: Fresh instal won't boot

Post by alfredmyers » 2019/09/24 21:09:07

This is the same bug described in RHEL 8.0's release notes and the solution described over there applies here as well.
1. Reboot the virtual machine.
2. During the booting process, select the required kernel using the up and down arrow keys on your keyboard.
3. Press the e key on your keyboard to edit the kernel command line.
4. Add systemd.unit=multi-user.target to the kernel command line in GRUB.
5. Press Ctrl-X to start the virtual machine.
6. After logging in, run the yum -y groupinstall base-x command.
7. Reboot the virtual machine to access the graphical mode.
PS.:

The key command here is in step #6.

Code: Select all

yum -y groupinstall base-x
The important part is getting access to the shell and for that, I'd rather either change to a virtual terminal or SSH into the VM instead of booting (steps 1 through 5).
Alfred Myers' blog

Martin8
Posts: 2
Joined: 2019/09/24 11:57:30

Re: Fresh instal won't boot

Post by Martin8 » 2019/09/24 21:22:47

Turns out, the default is install with a GUI. Which apparently doesn’t work inside a virtual environment... reinstall as minimal install, and it works fine.

thecdn
Posts: 1
Joined: 2014/11/19 13:15:43

Re: Fresh instal won't boot

Post by thecdn » 2019/09/25 14:38:17

The gui works on an install on vmware workstation pro 15.5. But I really hate the "Activities" minimal desktop. Is there a way to get back to the "Applications" version from Centos 7?

fiedzia
Posts: 8
Joined: 2018/08/16 06:43:31

Re: Fresh instal won't boot

Post by fiedzia » 2019/09/25 17:58:15

I would add similar note. Fail to load installation me in case of skip media check.

Arthur Cent
Posts: 1
Joined: 2019/10/24 18:17:11

Re: Fresh instal won't boot

Post by Arthur Cent » 2019/10/24 18:23:25

This RHEL 8 Hyper-V quick install instruction worked fine for me with CentOS 8 with Hyper-V:
https://developers.redhat.com/rhel8/ins ... l8-hyperv/

tomhong
Posts: 2
Joined: 2019/11/27 08:28:04

Re: Fresh instal won't boot

Post by tomhong » 2019/11/28 02:42:57

After some research, I found that installing CentOS 8 1905 on Hyper-V is generally ok with paying attention to startup-boot-order which you can adjust on VM's Setting/BIOS screen. But I've had the same problem of getting a black screen with a blinking prompt when installing Server with GUI.
My post on the other thread may help to resolve this issue when installing Server with GUI.

viewtopic.php?f=54&t=72618

Post Reply

Return to “CentOS 8 - General Support”