XRDP problem. Only ONE gnome session per user.

Issues related to applications and software problems and general support
Post Reply
gioir
Posts: 4
Joined: 2019/09/26 12:10:49

XRDP problem. Only ONE gnome session per user.

Post by gioir » 2019/09/26 12:40:07

Hello,
I have installed xrdp and tigervnc-server, and have enabled and started the xrdp.
If I login at the Graphic console (local), I cannot login via xrdp.
On the other hand, If I login via xrdp, I cannot login at the graphic console.
I have changed Policy parameter Policy=UBDC and restarted the xrdp, but nothing has been changed.
Please help me solve this problem.
Below are the log messages.
Thank you.

[xrdp.log]

Code: Select all

[20190926-21:05:11] [DEBUG] xrdp_wm_log_msg: connecting to sesman ip 127.0.0.1 port 3350
[20190926-21:05:12] [INFO ] xrdp_wm_log_msg: sesman connect ok
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: sending login info to session manager, please wait...
[20190926-21:05:12] [DEBUG] return value from xrdp_mm_connect 0
[20190926-21:05:12] [INFO ] xrdp_wm_log_msg: login successful for display 12
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC started connecting
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC connecting to 127.0.0.1 5912
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC tcp connected
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC security level is 2 (1 = none, 2 = standard)
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC password ok
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC sending share flag
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC receiving server init
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC receiving pixel format
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC receiving name length
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC receiving name
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC sending pixel format
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC sending encodings
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC sending framebuffer update request
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC sending cursor
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: VNC connection complete, connected ok
[20190926-21:05:12] [DEBUG] xrdp_wm_log_msg: connected ok
[20190926-21:05:12] [DEBUG] xrdp_mm_connect_chansrv: chansrv connect successful
[20190926-21:05:12] [DEBUG] Closed socket 19 (AF_INET 127.0.0.1:32802)
[20190926-21:05:13] [DEBUG] Closed socket 12 (AF_INET 192.168.5.128:3389)
[20190926-21:05:13] [DEBUG] xrdp_mm_module_cleanup
[20190926-21:05:13] [DEBUG] VNC mod_exit
[20190926-21:05:13] [DEBUG] Closed socket 20 (AF_INET 127.0.0.1:50566)
[20190926-21:05:13] [DEBUG] Closed socket 21 (AF_UNIX)
[xrdp-sesman.log]

Code: Select all

[[20190926-21:05:11] [INFO ] A connection received from 127.0.0.1 port 32802
[20190926-21:05:12] [INFO ] ++ created session (access granted): username user1, ip 192.168.5.1:5219 - socket: 12
[20190926-21:05:12] [INFO ] starting Xvnc session...
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:5910)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:6010)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:6210)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:5911)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:6011)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:6211)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:5912)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:6012)
[20190926-21:05:12] [DEBUG] Closed socket 12 (AF_INET 0.0.0.0:6212)
[20190926-21:05:12] [DEBUG] Closed socket 10 (AF_INET 127.0.0.1:3350)
[20190926-21:05:12] [INFO ] calling auth_start_session from pid 8741
[20190926-21:05:12] [DEBUG] Closed socket 9 (AF_INET 127.0.0.1:3350)
[20190926-21:05:12] [DEBUG] Closed socket 10 (AF_INET 127.0.0.1:3350)
[20190926-21:05:12] [INFO ] Xvnc :12 -auth .Xauthority -geometry 1280x800 -depth 32 -rfbauth /home/user1/.vnc/sesman_passwd-user1@localhost.localdomain:12 -bs -nolisten tcp -localhost -dpi 96  
[20190926-21:05:12] [CORE ] waiting for window manager (pid 8742) to exit
[20190926-21:05:13] [CORE ] window manager (pid 8742) did exit, cleaning up session
[20190926-21:05:13] [INFO ] calling auth_stop_session and auth_end from pid 8741
[20190926-21:05:13] [DEBUG] cleanup_sockets:
[20190926-21:05:13] [DEBUG] cleanup_sockets: deleting /tmp/.xrdp/xrdp_chansrv_audio_out_socket_12
[20190926-21:05:13] [DEBUG] cleanup_sockets: deleting /tmp/.xrdp/xrdp_chansrv_audio_in_socket_12
[20190926-21:05:13] [DEBUG] cleanup_sockets: deleting /tmp/.xrdp/xrdpapi_12
[20190926-21:05:13] [INFO ] ++ terminated session:  username user1, display :12.0, session_pid 8741, ip 192.168.5.1:5219 - socket: 12

jjasoncool
Posts: 2
Joined: 2019/10/27 05:23:16

Re: XRDP problem. Only ONE gnome session per user.

Post by jjasoncool » 2019/10/27 05:28:14

I have the same question.

no body using xrdp or xvnc here?

https://github.com/neutrinolabs/xrdp/issues/1432

User avatar
TrevorH
Forum Moderator
Posts: 27156
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: XRDP problem. Only ONE gnome session per user.

Post by TrevorH » 2019/10/28 13:48:12

CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

jjasoncool
Posts: 2
Joined: 2019/10/27 05:23:16

Re: XRDP problem. Only ONE gnome session per user.

Post by jjasoncool » 2019/10/28 16:12:08

TrevorH wrote:
2019/10/28 13:48:12
https://github.com/neutrinolabs/xrdp/issues/907 looks like the same thing.
I both have install xrdp and have same setting in centos7 and centos8.

Code: Select all

;; Policy - session allocation policy
; Type: enum [ "Default" | "UBD" | "UBI" | "UBC" | "UBDI" | "UBDC" ]
; Default: Xrdp:<User,BitPerPixel> and Xvnc:<User,BitPerPixel,DisplaySize>
; "UBD" session per <User,BitPerPixel,DisplaySize>
; "UBI" session per <User,BitPerPixel,IPAddr>
; "UBC" session per <User,BitPerPixel,Connection>
; "UBDI" session per <User,BitPerPixel,DisplaySize,IPAddr>
; "UBDC" session per <User,BitPerPixel,DisplaySize,Connection>
Policy=Default

[Logging]
LogFile=xrdp-sesman.log
LogLevel=DEBUG
EnableSyslog=1
SyslogLevel=DEBUG
But this issue is not happen in CentOS 7.

I have test to change policy to "UBDC" or "UBC".
This issue still exist.
I still need to logoff local account before I want to use RDP remote.

Post Reply

Return to “CentOS 8 - General Support”