avahi-ui-devel package missing

Issues related to applications and software problems and general support
Post Reply
xStatiCa
Posts: 4
Joined: 2009/04/02 18:48:08

avahi-ui-devel package missing

Post by xStatiCa » 2019/09/28 17:27:35

Where are the devel packages for avahi, avahi-ui, and avahi-ui-gtk3? I didn't see any devel packages for any of the avahi stuff. Did something change with CentOS 8 where those are not going to be provided?

The dependancy I am trying to satisfy to compile another src rpm (remmina) is pkgconfig(avahi-ui) and pkgconfig(avahi-ui-gtk).

George99
Posts: 58
Joined: 2013/09/08 17:01:05
Location: Germany

Re: avahi-ui-devel package missing

Post by George99 » 2019/09/28 18:23:10

avahi-devel is there you just have to enable PowerTools repo.

#dnf config-manager --set-enabled PowerTools

xStatiCa
Posts: 4
Joined: 2009/04/02 18:48:08

Re: avahi-ui-devel package missing

Post by xStatiCa » 2019/09/28 23:57:51

That did enable me to find avahi-devel but avahi-ui-devel seems to still be missing. avahi-devel has pkg-config files below.
/usr/lib64/pkgconfig/avahi-client.pc
/usr/lib64/pkgconfig/avahi-core.pc

The dependencies for pkg-config(avahi-ui) is still missing.
The files I am looking for are the pkg-config files for avahi-ui and avahi-ui-gtk3...
/usr/lib64/pkgconfig/avahi-ui.pc
/usr/lib64/pkgconfig/avahi-ui-gtk3.pc

That is what was provided in avahi-ui-devel it seems in CentOS 7.

EDIT: The spec in the src rpm for avahi in CentOS 8 shows a package for ui-devel so it is puzzling why it isn't in the repo.
%package ui-devel

User avatar
toracat
Forum Moderator
Posts: 7388
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: avahi-ui-devel package missing

Post by toracat » 2019/09/29 00:32:54

It is missing in RHEL 8 as well. There are those packages that have not been released for some unknown reason.
CentOS Forum FAQ

xStatiCa
Posts: 4
Joined: 2009/04/02 18:48:08

Re: avahi-ui-devel package missing

Post by xStatiCa » 2019/09/29 01:24:09

Avahi-ui-devel is there in CentOS 7... just missing in CentOS 8.

Post Reply

Return to “CentOS 8 - General Support”