Anyone successful in setting up VNC on CentOS 8?

Issues related to applications and software problems and general support
Post Reply
ncd
Posts: 13
Joined: 2015/02/23 22:16:43

Anyone successful in setting up VNC on CentOS 8?

Post by ncd » 2019/10/31 20:46:25

I've installed tigervnc-server and while it appears to work (see status) it fails to load for client machines.

I'm attempting this on CentOS 8 with Gnome.
The filrewall allows it to run on 5901/tcp and I'm using Remmina to view the session on Ubuntu. I'm also using 16bpp for the colour depth.

I've also, possibly mistakenly, made it so that the session request is handled by xorg in place of wayland by commenting out "WaylandEnable=false" in /etc.gdm/custom.conf

This is the output of the vnc status.

Code: Select all

● vncserver-toor@:1.service - Remote Desktop VNC Service
   Loaded: loaded (/etc/systemd/system/vncserver-toor@.service; enabled; vendor>
   Active: active (running) since Thu 2019-10-31 16:08:07 EDT; 21min ago
    Tasks: 290 (limit: 26213)
   Memory: 460.0M
   CGroup: /system.slice/system-vncserver\x2dtoor.slice/vncserver-toor@:1.servi>
           ├─16394 /usr/bin/Xvnc :2 -auth /home/toor/.Xauthority -desktop local>
           ├─16415 sh -c (/home/toor/.vnc/xstartup; /usr/bin/vncserver -kill :2>
           ├─16416 /bin/sh /home/toor/.vnc/xstartup
           ├─16417 /usr/libexec/gnome-session-binary
           ├─16432 dbus-launch --sh-syntax --exit-with-session
           ├─16433 /usr/bin/dbus-daemon --syslog --fork --print-pid 6 --print-a>
           ├─16463 /usr/bin/ssh-agent /etc/X11/xinit/Xclients
           ├─16493 /usr/libexec/at-spi-bus-launcher
           ├─16498 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-sp>
           ├─16501 /usr/libexec/at-spi2-registryd --use-gnome-session
           ├─16505 /usr/libexec/gvfsd
           ├─16512 /usr/libexec/gvfsd-fuse /home/toor/.gvfs -f -o big_writes
           ├─16538 /usr/bin/gnome-keyring-daemon --start --components=secrets
           ├─16552 /usr/bin/gnome-shell
           ├─16613 ibus-daemon --xim --panel disable
           ├─16617 /usr/libexec/ibus-dconf
           ├─16618 /usr/libexec/ibus-extension-gtk3
lines 1-23
When I connect, the viewer crashes. No error, it just closes the window and that's that.

If anyone has had success let me know. Thanks.

Post Reply

Return to “CentOS 8 - General Support”