Application package does not compile

Issues related to applications and software problems and general support
User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/11/29 16:28:16

BShT wrote:
2019/11/29 15:23:23
because you need an old ssl package

Good. Then why doesn’t help ./configure --without-ssl ?

Code: Select all

./configure --without-ssl
.............
checking for SSL_accept in -lssl... yes
checking for BN_init in -lcrypto... no
configure: error: TORQUE needs lib crypto (often openssl-devel) in order to build

BShT
Posts: 116
Joined: 2019/10/09 12:31:40

Re: Application package does not compile

Post by BShT » 2019/11/29 16:58:19

this is not a CentOS issue you should check the solution with the developer...

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/02 06:46:19

BShT wrote:
2019/11/29 16:58:19
this is not a CenttOS issue you should check the solution with the developer...
This is not a CenttOS issue ,...Well.And why then the compilation of this program is accomplished without problems with CentOS 7?

User avatar
jlehtone
Posts: 2432
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Application package does not compile

Post by jlehtone » 2019/12/02 12:09:05

It is not a CentOS issue that something third-party "works".
kerogaz wrote:
2019/11/29 08:01:36
4.2.4.1 is specific package of universite I remember it was incompatible even with 4.2.6.1. On the cluster on all nodes is sentos 6 and centos 7 with torque 4.2.4.1. Cluster is stable since 2012 and I would not want to break it with innovations And I started using 8 just because support 6 ends
If you don't want to break the cluster with an upgrade, then you don't upgrade torque or OS to "innovations". Install CentOS 7 to the node.

BShT
Posts: 116
Joined: 2019/10/09 12:31:40

Re: Application package does not compile

Post by BShT » 2019/12/02 13:20:11

you can try to install IE6 on Centos and then blame Centos

this is exactly what you are doing...

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/03 12:40:51

Only torque6.1.1.1 is compiled here, but make gives errors

Code: Select all

torque-6.1.1.1]# make
Making all in src
make[1]: Entering directory '/torque-6.1.1.1/src'
Making all in include
make[2]: Entering directory '/torque-6.1.1.1/src/include'
cp site_job_attr_def.ht site_job_attr_def.h
cp site_job_attr_enum.ht site_job_attr_enum.h
cp site_qmgr_node_print.ht site_qmgr_node_print.h
cp site_qmgr_que_print.ht site_qmgr_que_print.h
cp site_qmgr_svr_print.ht site_qmgr_svr_print.h
cp site_que_attr_def.ht site_que_attr_def.h
cp site_que_attr_enum.ht site_que_attr_enum.h
cp site_svr_attr_def.ht site_svr_attr_def.h
cp site_svr_attr_enum.ht site_svr_attr_enum.h
make  all-am
make[3]: Entering directory '/torque-6.1.1.1/src/include'
make[3]: Leaving directory '/torque-6.1.1.1/src/include'
make[2]: Leaving directory '/torque-6.1.1.1/src/include'
Making all in lib
make[2]: Entering directory '/torque-6.1.1.1/src/lib'
Making all in Libattr
make[3]: Entering directory '/torque-6.1.1.1/src/lib/Libattr'
make[4]: Entering directory '/torque-6.1.1.1/src/lib/Libattr'
g++ -DHAVE_CONFIG_H -I. -I../../../src/include  -I../../../src/include `xml2-config --cflags`   -g -D_LARGEFILE64_SOURCE  -W -Wall -Wextra -Wno-unused-parameter -Wno-long-long -Wpedantic -Werror -Wno-sign-compare -MT attr_atomic.o -MD -MP -MF .deps/attr_atomic.Tpo -c -o attr_atomic.o attr_atomic.c
mv -f .deps/attr_atomic.Tpo .deps/attr_atomic.Po
g++ -DHAVE_CONFIG_H -I. -I../../../src/include  -I../../../src/include `xml2-config --cflags`   -g -D_LARGEFILE64_SOURCE  -W -Wall -Wextra -Wno-unused-parameter -Wno-long-long -Wpedantic -Werror -Wno-sign-compare -MT attr_fn_acl.o -MD -MP -MF .deps/attr_fn_acl.Tpo -c -o attr_fn_acl.o attr_fn_acl.c
attr_fn_acl.c: In function ‘int set_allacl(pbs_attribute*, pbs_attribute*, batch_op, int (*)(char*, char*))’:
attr_fn_acl.c:502:20: error: this statement may fall through [-Werror=implicit-fallthrough=]
       pas->as_next = pas->as_buf;
       ~~~~~~~~~~~~~^~~~~~~~~~~~~
attr_fn_acl.c:506:5: note: here
     case INCR_OLD:
     ^~~~
cc1plus: all warnings being treated as errors
make[4]: *** [Makefile:497: attr_fn_acl.o] Error 1
make[4]: Leaving directory '/torque-6.1.1.1/src/lib/Libattr'
make[3]: *** [Makefile:557: all-recursive] Error 1
make[3]: Leaving directory '/torque-6.1.1.1/src/lib/Libattr'
make[2]: *** [Makefile:392: all-recursive] Error 1
make[2]: Leaving directory '/torque-6.1.1.1/src/lib'
make[1]: *** [Makefile:403: all-recursive] Error 1
make[1]: Leaving directory '/torque-6.1.1.1/src'
make: *** [Makefile:586: all-recursive] Error 1

User avatar
jlehtone
Posts: 2432
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Application package does not compile

Post by jlehtone » 2019/12/03 16:31:55

That seems unrelated, because you are limited to custom torque-4.2.4.1?

(We've been using SLURM for years. Not yet with 8 though.)

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/04 06:24:19

Yes, but I just wanted to know if I could install at least some kind of torques on Centos 8. It's impossible.So for computing clusters Centos 8 is not suitable

User avatar
kerogaz
Posts: 36
Joined: 2019/11/28 09:09:01

Re: Application package does not compile

Post by kerogaz » 2019/12/04 07:56:12

For the sake of interest, I tried to install 4.2.4.1 on Debian 10

Code: Select all

checking for SSL_accept in -lssl... yes
checking for BN_init in -lcrypto... no
configure: error: TORQUE needs lib crypto (often openssl-devel) in order to build
root@debian:~/torque-4.2.4.1#

Does this mean that the era of parallel computing Linux is over? :lol:

User avatar
jlehtone
Posts: 2432
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Application package does not compile

Post by jlehtone » 2019/12/04 09:33:00

No. You are making unjustified generalization. The same happens, if you assume all users to be complete idiots after encountering one poorly educated user.


Can you explain these two issues:

Code: Select all

configure: error: TORQUE needs lib crypto

Code: Select all

attr_fn_acl.c: In function ‘int set_allacl(pbs_attribute*, pbs_attribute*, batch_op, int (*)(char*, char*))’:
attr_fn_acl.c:502:20: error: this statement may fall through [-Werror=implicit-fallthrough=]
       pas->as_next = pas->as_buf;
       ~~~~~~~~~~~~~^~~~~~~~~~~~~
attr_fn_acl.c:506:5: note: here
     case INCR_OLD:
     ^~~~
cc1plus: all warnings being treated as errors
(Hint: They are not about Linux.)

Post Reply

Return to “CentOS 8 - General Support”