Brocade 1020 won't work

Issues related to hardware problems
Post Reply
mros73
Posts: 4
Joined: 2019/09/28 12:37:58

Brocade 1020 won't work

Post by mros73 » 2019/09/28 12:40:21

Hi!

My Brocade 1020 NIC won't work on CentOS 8.
nmcli will not even list it.

It worked perfectly fine in 7.6, never tried 7.7.
What can I do?

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Brocade 1020 won't work

Post by toracat » 2019/09/28 16:10:59

What is the output of:

lspci -nn | grep -i net
CentOS Forum FAQ

mros73
Posts: 4
Joined: 2019/09/28 12:37:58

Re: Brocade 1020 won't work

Post by mros73 » 2019/09/28 18:30:03

Yeah, I had that idea, too.
Problem is: "lspci" isn't available anymore in 8.

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Brocade 1020 won't work

Post by toracat » 2019/09/28 18:32:56

lspci is installed by pciutils.
CentOS Forum FAQ

mros73
Posts: 4
Joined: 2019/09/28 12:37:58

Re: Brocade 1020 won't work

Post by mros73 » 2019/09/28 19:44:33

Thanks, I didn't know that!

lspci indeed lists the Adapter (it's 2, there's 2 on the PCI-E-Card):

Code: Select all

04:00.0 Fibre Channel: Cavium QLogic 1010/1020/1007/1741 10Gbps CNA (rev 01)
04:00.1 Fibre Channel: Cavium QLogic 1010/1020/1007/1741 10Gbps CNA (rev 01)
04:00.2 Ethernet controller: Cavium QLogic 1010/1020/1007/1741 10Gbps CNA (rev 01)
04:00.3 Ethernet controller: Cavium QLogic 1010/1020/1007/1741 10Gbps CNA (rev 01)

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Brocade 1020 won't work

Post by toracat » 2019/09/29 00:13:34

Please type the command as presented. Once again,

lspci -nn | grep -i net
CentOS Forum FAQ

mros73
Posts: 4
Joined: 2019/09/28 12:37:58

Re: Brocade 1020 won't work

Post by mros73 » 2019/09/29 02:13:40

*oups* sorry!

Here it is:

Code: Select all

00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I218-V [8086:15a1]
04:00.2 Ethernet controller [0200]: Cavium QLogic 1010/1020/1007/1741 10Gbps CNA [1657:0014] (rev 01)
04:00.3 Ethernet controller [0200]: Cavium QLogic 1010/1020/1007/1741 10Gbps CNA [1657:0014] (rev 01)

User avatar
toracat
Forum Moderator
Posts: 7386
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Brocade 1020 won't work

Post by toracat » 2019/09/29 05:42:34

I see that device ID pairing [1657:0014] is in CentOS 7 but not in CentOS 8. You may want to file a request to build the driver(s) for your device at ELRepo's bug tracker.
CentOS Forum FAQ

@Bruno
Posts: 1
Joined: 2019/10/01 10:54:15

Re: Brocade 1020 won't work

Post by @Bruno » 2019/10/01 11:10:55

toracat wrote:
2019/09/28 18:32:56
lspci is installed by pciutils.
Didn't know that it was possible... Thanks for your advice :D

Post Reply

Return to “CentOS 8 - Hardware Support”