CentOS doesn't see HDD on Dell R710 Server

Issues related to hardware problems
Post Reply
jeremiahlandi
Posts: 1
Joined: 2019/11/26 06:39:03

CentOS doesn't see HDD on Dell R710 Server

Post by jeremiahlandi » 2019/11/26 06:46:28

Hello all,

I am running a Dell R701 with the following specifications:
• Dell PowerEdge R710 Server
• 2 L5520 Procs
• Perc 6/i RAID
• 1TB SSD
I am trying to install the latest version of CentOS (CentOS-Stream-x86_64-dvd1.iso) onto the server via the USB port on the front of the machine.
When I go to run the installation from the USB stick it goes through the normal process; however, does not show any hard drives. I have narrowed the issue down to the RAID that is associated with the R710; however, I have not been able to overcome this issue.

I first tried botting into “rescue Mode” and using the `dmraid -r -E /dev/sdb`; however, the command line said that it couldn’t find the dmraid command. I moved onto the second command `dd if=/dev/zero of=/dev/sda bs=1024 count=20`. The second `dd~ command string ran without any issues, but I wasn't sure how to kick off the installation after running it.
When I reboot the R710 the system no longer finds the virtual RAID and makes me setup the RAID again which continues the vicious cycle all over again.

I was wondering if someone could help out and let me know how I could kick off the installation without having to reboot the machine causing me to have to reconfigure the RAID.

My next step is to try and install CentOS 6 and see if the kicks the issue or not. I have read on forums that older versions of CentOS handle the RAID better hopefully preventing me from having to do all this workaround.

Research Done:
• CentOS7 installer fails to see HDDs [SOLVED] – CentOS viewtopic.php?t=49069
viewtopic.php?t=55898
https://centosfaq.org/centos/centos-ins ... ard-drive/
• Re: Can't find hard disk where to install CentOS 7 viewtopic.php?f=47&t=56499

User avatar
TrevorH
Forum Moderator
Posts: 27156
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS doesn't see HDD on Dell R710 Server

Post by TrevorH » 2019/11/26 07:30:16

I'm pretty sure that the RAID controller in an R710 is too old to be supported by CentOS 8. In addition, you say you will try CentOS 6 but that only has 1 year of life left. CentOS 7 should support it so I'd use that.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 8 - Hardware Support”