VNC via xorg: authentication failed

Issues related to software problems.
Post Reply
User avatar
Zane
Posts: 34
Joined: 2009/09/14 08:37:48
Location: Ferrara, Italy
Contact:

VNC via xorg: authentication failed

Post by Zane » 2011/02/02 11:41:59

I all,
I'm wasting hours on this problem: I'm setting up an always-connectable VNC server loaded via xorg.conf.

This is what I did:

[code]yum install vnc-server[/code]

[code]gedit /etc/X11/xorg.conf[/code]

[code]Section "Module"
Load "vnc"
EndSection[/code]

[code]Section "Screen"
......
Option "SecurityTypes" "VncAuth"
Option "UserPasswdVerifier" "VncAuth"
Option "PasswordFile" "/etc/vncpassword"
.....
EndSection[/code]

[code]vncpasswd "/etc/vncpassword"[/code]
I rebooted.

The server is up and running, port 5900 is open, but when I try to connect and provide the password I get

[quote]VNC authentication failed![/quote]
The password I provide is right (I also tried to change it, just in case).

The fun thing is: I just did the same on another machine yesterday (the only difference being it was a fisical machine, now I'm on a VM) and it worked!

Any help is appreciated, thanks!

User avatar
Zane
Posts: 34
Joined: 2009/09/14 08:37:48
Location: Ferrara, Italy
Contact:

Re: VNC via xorg: authentication failed

Post by Zane » 2011/02/02 15:29:31

I found the problem! It's VirtualBox Guest Additions!

This is the xorg.config I was using

[code]# VirtualBox generated configuration file
# based on /etc/X11/xorg.conf.

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "Protocol" "Standard"
Option "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "vboxmouse"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "VirtualBox Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Oracle Corporation"
Option "ZAxisMapping" "4 5"
Option "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
ModelName "VirtualBox Virtual Output"
VendorName "Oracle Corporation"
EndSection

Section "Device"
BoardName "VirtualBox Graphics"
Driver "vboxvideo"
Identifier "Device[0]"
VendorName "Oracle Corporation"
EndSection

Section "Screen"
SubSection "Display"
Depth 24
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
Option "PasswordFile" "/etc/vncpassword"
EndSection

Section "Module"
Load "vnc"
EndSection[/code]
Switching to the backup copy did the trick

[code]# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
Option "PasswordFile" "/etc/vncpassword"
EndSection

Section "Module"
Load "vnc"
EndSection[/code]
Out of curiosity only: any idea what is going on here?

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

VNC via xorg: authentication failed

Post by pschaff » 2011/02/02 21:52:44

Not sure what's going on there. I have a lot of VB CentOS 5 systems and have had no recent issues with xorg.conf, but then I have not used VNC on them. Are you following [url=http://wiki.centos.org/HowTos/VNC-Server]HowTos/VNC-Server[/url] on the Wiki?

User avatar
Zane
Posts: 34
Joined: 2009/09/14 08:37:48
Location: Ferrara, Italy
Contact:

Re: VNC via xorg: authentication failed

Post by Zane » 2011/02/05 16:39:31

Hi Phil,
thanks for you reply :-)

Since I need it "always on", (check my conf before).[url=http://wiki.centos.org/HowTos/VNC-Server#head-7e0dadd72b0ddd9c84381b053b440d251d4a9c8b]I configured it this way[/url]. Again, it works as expected when editing the original xorg.conf, but it doesn't if you do the same to the one modified by Guest Additions.

Post Reply

Return to “CentOS 5 - Software Support”